Bug 19116 - rsync over ssh exit status 20
Summary: rsync over ssh exit status 20
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rsync (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-14 20:48 UTC by Need Real Name
Modified: 2014-03-17 02:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 03:18:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-14 20:48:10 UTC
I'm using rsync (via OpenSSH) to backup a server, but for some reasons it 
exits with a code 20. It doesn't print any error-texts or warnings, and it 
seems to backup correctly - but the non-zero status concerns me...

I use a RedHat 7 with all updates installed.

Could it be because the server holds more than 65536 files??? If I exclude 
some more dirs (for instance /usr), so that fewer files are copied, it 
exits correctly with a 0 status!

I've included my backup-script below.

(BTW: everything worked under RedHat 6.2)

----8<----
#!/bin/sh
EXCLUDEFILE='/etc/backup-exclude'

HERE='/backup/mirror'
REMOTE='root@mysource.dk:/'

OPTIONS='-a --force --delete -e /usr/bin/ssh'

rsync   $OPTIONS \
        --exclude-from $EXCLUDEFILE \
        $REMOTE $HERE
echo $?
----8<----

/etc/backup-exclude contains:

----8<----
/proc
/mnt
----8<----

Comment 1 Bill Nottingham 2001-01-18 18:23:59 UTC
rsync exits 20 when interrupted with SIGINT, or SIGUSR1. Neither
appears to apply in your case, which is odd.

Comment 2 Karl schmidt 2001-02-26 03:17:57 UTC
I was having similar problems using rsych with ssh - I updated to version
2.4.6-1 direct from rsync and things seem to be working fine for now - I'm
running RH 7 with updates.

Comment 3 Bill Nottingham 2001-06-12 19:55:50 UTC
ok, marking as resolved in the current release. Please re-open if it persists
with the 2.4.6 package from 7.1 (it should run fine on 7.0).

FWIW, we haven't seen this in testing here.


Note You need to log in before you can comment on or make changes to this bug.