Bug 191160 - high cpu usage after fail login attempts
high cpu usage after fail login attempts
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vino (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Desktop
Depends On:
Blocks: 210855
  Show dependency treegraph
Reported: 2006-05-09 06:53 EDT by Johnny Hughes
Modified: 2014-06-18 05:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0727
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-07-24 15:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to correct this issue in the spec file. (2.66 KB, patch)
2006-05-09 06:53 EDT, Johnny Hughes
no flags Details | Diff
vino-2.8.1-remove-io-watch-when-client-on-hold.patch (3.22 KB, patch)
2006-10-19 11:27 EDT, Mark McLoughlin
no flags Details | Diff

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 332011 None None None Never

  None (edit)
Description Johnny Hughes 2006-05-09 06:53:25 EDT
Description of problem:
After failed login attempts on vino, CPU usage climbs to (and stays) between 30-50%.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Attempt a login to vino with a bad password.

Actual results:
Processor usage in top increase to between 30-50%

Expected results:
Login fails and vino is ready for another login attempt

Additional info:
This problem has been report to CentOS as there is at test rpm available that
fixes the problem here:

Comment 1 Johnny Hughes 2006-05-09 06:53:26 EDT
Created attachment 128775 [details]
patch to correct this issue in the spec file.
Comment 2 Mark McLoughlin 2006-10-19 11:27:43 EDT
Created attachment 138879 [details]
Comment 3 Mark McLoughlin 2006-10-19 11:29:20 EDT
Attached a slightly more up to date version of the fix from upstream CVS HEAD

Upstream bug:

Comment 9 Cameron Meadors 2008-06-13 11:23:40 EDT
I cannot reproduce the high cpu usage on a failed login.
Comment 11 Søren Sandmann Pedersen 2008-06-18 17:11:03 EDT
I can definitely reproduce this. I have it on a machine in the office if you
want to see it.
Comment 12 Cameron Meadors 2008-06-23 16:21:44 EDT
Reproduced and verified fixed.
Comment 14 errata-xmlrpc 2008-07-24 15:57:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.