Bug 191174 - inaccurate error message when missing '-f' for kernel updates in default config
inaccurate error message when missing '-f' for kernel updates in default config
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
Depends On:
Blocks: 179644 181409
  Show dependency treegraph
 
Reported: 2006-05-09 11:10 EDT by James Bowes
Modified: 2013-01-10 04:49 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2006-0494
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 17:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Beth Nackashi 2006-06-02 12:29:02 EDT
Test plan:
1-  Kickstart system to RHEL4 U2.
2-  Install latest up2date and rhnlib from devserv.devel:/mnt/redhat/dist/4E-U4.
3-  Verify /etc/sysconfig/rhn/up2date says "pkgSkipList=kernel*;"
4-  Register system (up2date --nox --register) to webqa or a satellite that has
RHEL4 U3 synced so there will be kernel updates available for the client.
5-  Run up2date --nox -l.
6-  Run up2date --nox  -d kernel kernel-doc kernel-smp kernel-source.
Comment 4 Beth Nackashi 2006-06-02 13:03:36 EDT
Retested on x86_84 with up2date-4.4.69-11 and rhnlib-1.8.7-1.

With
pkgSkipList=kernel*;pkgsToInstallNotUpdate=kernel;kernel-modules;kernel-devel;removeSkipList=kernel*;

[root@bnackash-64 tmp]# up2date-nox -l|grep -A5 skipped
The following Packages were marked to be skipped by your configuration:

Name                                    Version        Rel  Reason
-------------------------------------------------------------------------------
kernel                                  2.6.9          34.ELPkg name/pattern
kernel-utils                            2.4            13.1.80Pkg name/pattern

[root@bnackash-64 tmp]# up2date --nox  -d kernel kernel-doc kernel-smp kernel-source

Fetching Obsoletes list for channel: rhel-x86_64-as-4...
########################################

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-x86_64...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------

The following Packages were marked to be skipped by your configuration:

Name                                    Version        Rel  Reason
-------------------------------------------------------------------------------
kernel                                  2.6.9          34.ELPkg name/pattern
kernel-doc                              2.6.9          34.ELPkg name/pattern
kernel-smp                              2.6.9          34.ELPkg name/pattern
kernel-utils                            2.4            13.1.80Pkg name/pattern


The following packages you requested were not found:
kernel-source

The following packages you requested were marked to be skipped by your
configuration:
kernel
kernel-doc
kernel-smp

With all lists = [] (to make sure nothing got broken):
[root@bnackash-64 tmp]# up2date --nox  -d kernel kernel-doc kernel-smp kernel-source

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-x86_64...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
kernel                                  2.6.9          34.EL             x86_64
kernel-doc                              2.6.9          34.EL             noarch
kernel-smp                              2.6.9          34.EL             x86_64


Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.6.9-34.EL.x86_64.r ########################## Done.                   
kernel-doc-2.6.9-34.EL.noar ########################## Done.                   
kernel-smp-2.6.9-34.EL.x86_ ########################## Done. 


Comment 5 Beth Nackashi 2006-06-02 13:05:04 EDT
[root@bnackash-64 tmp]# up2date -f kernel

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-x86_64...

Name                                    Version        Rel     
----------------------------------------------------------
kernel                                  2.6.9          34.EL             x86_64


Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.6.9-34.EL.x86_64.r ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:kernel                 ########################################### [100%]
Comment 7 Red Hat Bugzilla 2006-08-01 17:13:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0494.html

Note You need to log in before you can comment on or make changes to this bug.