Bug 191179 - up2date +get source fails if no source available
up2date +get source fails if no source available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Beth Nackashi
:
: 197689 (view as bug list)
Depends On:
Blocks: 179644 181409
  Show dependency treegraph
 
Reported: 2006-05-09 11:21 EDT by James Bowes
Modified: 2013-01-10 04:49 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0494
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-01 17:15:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Beth Nackashi 2006-06-02 14:33:25 EDT
Packages tested:
rhnlib-1.8.2-1.p23.1
up2date-4.4.67-4

The fixed up2date package for RHEL4 U4 has slightly different behavior than the
fixed up2date package for RHEL3 U8 for i386 arch.  In U8, up2date gives this
warning if the source RPM is not found:

"warning: source RPM for acroread was not found."

In U4, up2date gives this warning if the source RPM is not found:

File Not Found: 
File Not Found: acroread-7.0.1-1.2.0.EL4.src.rpm

Error Message:
    Invalid RPM package acroread-7.0.1-1.2.0.EL4.src.rpm requested
Error Class Code: 17
Error Class Info: File not found.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

i386 arch seems to be the only outlier.

In all cases, the RPM gets retrieved and placed in /var/spool/up2date regardless
of availability of the source RPM.  I am marking this bug VERIFIED.
Comment 4 Beth Nackashi 2006-06-02 14:37:46 EDT
Correction to Comment #3 -- that was user error.  I had forgotten to install the
fixed version of up2date on my i386 box.  With the *correct* version, the
warning is output on i386 as expected:

"warning: source RPM for acroread was not found."
Comment 6 James Bowes 2006-07-05 16:06:50 EDT
*** Bug 197689 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla 2006-08-01 17:15:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0494.html

Note You need to log in before you can comment on or make changes to this bug.