Bug 191185 - Geronimo-specs update causing dependency problem with pup/yum
Geronimo-specs update causing dependency problem with pup/yum
Product: Fedora
Classification: Fedora
Component: geronimo-specs (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Gary Benson
Depends On:
  Show dependency treegraph
Reported: 2006-05-09 12:37 EDT by Penelope Fudd
Modified: 2008-03-12 01:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-12 01:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2006-05-09 12:37:53 EDT
Description of problem:
When running pup or yum, update can't complete because geronimo-specs-compat
depends on old geronimo-specs.

Version-Release number of selected component (if applicable):
geronimo-specs.noarch 0:1.0-0.M2.3jpp
geronimo-specs = 1.0-0.M2.2jpp_7fc

How reproducible:
All the time

Steps to Reproduce:
1. yum update
Actual results:
Error: Missing Dependency: geronimo-specs = 1.0-0.M2.2jpp_7fc is needed by
package geronimo-specs-compat

Expected results:

Additional info:
Comment 2 Gary Benson 2006-05-19 09:48:18 EDT
Penelope, it looks like you've added the JPackage yum repository.  This can
cause strange interactions.  If you let me know what were you trying to achieve
I can perhaps give you some advice.
Comment 3 Mike Detwiler 2006-05-19 11:32:26 EDT
(In reply to comment #2)
> Penelope, it looks like you've added the JPackage yum repository.  This can
> cause strange interactions.

The Fedora Wiki's JavaFAQ page and the Paul Howarth's helpful JpackageJava
instructions (which are linked to from tha JavaFAQ) seem to imply that Fedora
Java and JPackage Java are "fully compatible" and that it should not be a
problem to have both Fedora and JPackage repositories enabled.


In fact Paul's page recommends setting up the JPackage repo. While section 15.2
of the Fedora Core 5 Release Notes specifically points out the potential
problems of doing so, IMHO most people coming to Fedora hoping to use Java don't
consult the release notes for Java information. If they are like me, they first
find their way to the Wiki's JavaFAQ page and start from there. Perhaps the
JavaFAQ page should make mention of the potential compatibility problems with
JPackage and Fedora Java packages and reference the relevant section of the
release notes. This might help to reduce these kinds of bug reports.
Comment 4 Penelope Fudd 2006-05-20 01:58:24 EDT
Sigh.  Yes, I think Mike's got it.

The goal was to get Java running in Firefox, enabling Java applets on web pages.
 From everything I'd read, the solution involved using the JPackage repo.

And it actually worked!  I've got Java running in my browser.  There were no

However, that's changed.  When I run Pup (or yum), there are two packages that I
cannot update.  One of which is Geronimo, because it depends on geronimo-specs
(or vice-versa).  I'm not at the computer with FC5 right now, so I can't say
what the other one was.

It might be a good idea to modify pup or yum to say that the conflict is caused
by something from a non-Fedora repository, and that the best solution may be to
remove that repository.  The program already knows the cause of the problem, it
just needs to tell the user, so that the user doesn't complain to the wrong
people.  Or maybe put an icon next to each package, indicating its source.

Additionally, to solve this dependency conflict I tried to remove
geronimo-specs-compat, but other things depend on it, and I dreaded having an
expanding list of things I'd have to remove, so I stopped.
Comment 5 Gary Benson 2006-05-22 04:30:47 EDT
Ok, what's happening is that the geronimo-specs package in the JPackage repo is
newer than the one in the Fedora repo, so yum/pup/whatever is trying to upgrade
the Fedora package with the JPackage one.  The problem is that the Fedora one
has a bunch of extra stuff (ie geronimo-specs-compat) which doesn't exist in the
JPackage one. (Specifically, geronimo-specs-compat is a bunch of links that
allows geronimo-specs to replace seven non-free JPackage packages that could not
be built in Fedora).

The root cause should be fixed for FC6 but is unlikely to be fixed in FC5. 
Until then, one way to remedy this would be to tell yum not to try and upgrade
geronimo-specs.  Adding a line like "exclude=geronimo-specs" to your
/etc/yum.conf ought to allow you to work around it.  Let me know if it works...
Comment 6 Fernando Nasser 2006-05-23 09:31:24 EDT
Gary, as the new geronimo-specs (fro FC6) already has (or is supposed to have
;-) ) the mechanisms to work like a replacement for those non-free API packages,
we will have to add an "Obsoletes: geronimo-specs-compat" so it causes it to be
removed, right?  But geronimo-specs has many subpackages, and several of them
must be brought simultaneously before geronimo-specs-compat can be removed.  I
wonder if yum and others will figure it outr by themselves or if we will need to
so something else to make things work.

If we can make this upgrading work automatically, if the current geronimo-specs
from JPackage already has what is provided by geronimo-specs-compat we could
respin the JPP one with the proper Obsoletes or whatever and solve the
repository incompatibilities...
Comment 7 Gary Benson 2006-05-23 09:53:53 EDT
Nothing in FC5 explicitly requires geronimo-specs-compat: dependencies are all
virtual (ejb, j2ee-connector, j2ee-deployment, j2ee-management, jacc, jms and
jta).  As long as these are provided by something, or packages are updated to
not require these, then there will be nothing preventing geronimo-specs-compat
from being uninstalled.

You're right that there will have to be an "Obsoletes: geronimo-specs-compat" to
make it get removed (is there a main geronimo-specs package this can go in) but
there should be no need to "Provides: geronimo-specs-compat" anywhere.
Comment 8 Penelope Fudd 2006-06-14 18:59:48 EDT
The suggestion fixed the conflict!
Comment 9 Penelope Fudd 2007-02-10 17:37:09 EST
Err, sorry, can this be marked as completed now?
Comment 10 petrosyan 2008-03-12 01:47:09 EDT
Penelope, since you are the reporter of this bug you can mark it as RESOLVED
yourself in the future.

Note You need to log in before you can comment on or make changes to this bug.