Bug 191198 - fsck.vfat does not work with disk image files
fsck.vfat does not work with disk image files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dosfstools (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-09 14:23 EDT by Peter van Hooft
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 08:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to spec file for 2.10-3 (863 bytes, patch)
2006-05-09 14:23 EDT, Peter van Hooft
no flags Details | Diff

  None (edit)
Description Peter van Hooft 2006-05-09 14:23:22 EDT
Description of problem:
fsck.vfat does not work on image file of a disk partition.

Version-Release number of selected component (if applicable):
2.10-3 (but it is the same in 2.11-4.2, I believe)

How reproducible:
Run fsck.vfat on a disk image file.

Steps to Reproduce:
1.fsck.vfat image-file
2.
3.
  
Actual results:
open hda5:File too large

Expected results:
It should fsck the image file.

Additional info:

I propose to skip the llseek.patch and build with
CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
instead of
CFLAGS="$RPM_OPT_FLAGS -Dllseek=lseek64 -D_LARGEFILE64_SOURCE"

This works with image files, it still needs to be tested on real disks and on
64-bit platforms.
Comment 1 Peter van Hooft 2006-05-09 14:23:23 EDT
Created attachment 128805 [details]
Patch to spec file for 2.10-3
Comment 2 Peter Vrabec 2006-05-10 12:46:13 EDT
I can't reproduce it.

# dd if=/dev/zero of=testFile bs=1M count=10
10+0 records in
10+0 records out
10485760 bytes (10 MB) copied, 0.156701 seconds, 66.9 MB/s
# mkdosfs testFile
mkdosfs 2.11 (12 Mar 2005)
# fsck.vfat testFile
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
testFile: 0 files, 0/5101 clusters

same result with dosfstool-2.10-3
Comment 3 Peter van Hooft 2006-05-11 02:32:52 EDT
You need to create a file larger than 4 GB for this problem to appear...
Hence the need for the -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 flags.
Comment 4 Peter Vrabec 2006-05-11 08:01:48 EDT
thanks, 
it's fixed in dosfstools-2.11-5 and dosfstools-2.11-5.FC5 
 

Note You need to log in before you can comment on or make changes to this bug.