Bug 191267 - internal compiler error: in coalesce_abnormal_edges, at tree-outof-ssa.c:646
internal compiler error: in coalesce_abnormal_edges, at tree-outof-ssa.c:646
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 07:10 EDT by Peter Robinson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-11 04:38:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (743.78 KB, application/octet-stream)
2006-05-10 07:10 EDT, Peter Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 27549 None None None Never

  None (edit)
Description Peter Robinson 2006-05-10 07:10:38 EDT
Got the above compiler error and it mentions to bugzilla it. So here it is!

if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..  -DPOSIX   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables   -MT xmlprinter.lo -MD -MP -MF
".deps/xmlprinter.Tpo" -c -o xmlprinter.lo xmlprinter.cc; \
then mv -f ".deps/xmlprinter.Tpo" ".deps/xmlprinter.Plo"; else rm -f
".deps/xmlprinter.Tpo"; exit 1; fi
../../talk/xmllite/qname.h: In constructor 'buzz::QName::Data::Data(const
std::string&, const std::string&)':
../../talk/xmllite/qname.h:77: warning: 'buzz::QName::Data::refcount_' will be
initialized after
../../talk/xmllite/qname.h:70: warning:   'std::string
buzz::QName::Data::namespace_'
../../talk/xmllite/qname.h:63: warning:   when initialized here
/bin/sh ../../libtool --silent --tag=CXX --mode=link g++  -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables     -o
libjinglexmllite-0.3.la -rpath /usr/lib  qname.lo xmlbuilder.lo xmlconstants.lo
xmlelement.lo xmlnsstack.lo xmlparser.lo xmlprinter.lo -lexpat
make[3]: Leaving directory `/usr/src/redhat/BUILD/libjingle-0.3.0/talk/xmllite'
Making all in xmpp
make[3]: Entering directory `/usr/src/redhat/BUILD/libjingle-0.3.0/talk/xmpp'
if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..  -DPOSIX   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables   -MT constants.lo -MD -MP -MF
".deps/constants.Tpo" -c -o constants.lo constants.cc; \
then mv -f ".deps/constants.Tpo" ".deps/constants.Plo"; else rm -f
".deps/constants.Tpo"; exit 1; fi
../../talk/xmllite/qname.h: In constructor 'buzz::QName::Data::Data(const
std::string&, const std::string&)':
../../talk/xmllite/qname.h:77: warning: 'buzz::QName::Data::refcount_' will be
initialized after
../../talk/xmllite/qname.h:70: warning:   'std::string
buzz::QName::Data::namespace_'
../../talk/xmllite/qname.h:63: warning:   when initialized here
if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..  -DPOSIX   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables   -MT jid.lo -MD -MP -MF
".deps/jid.Tpo" -c -o jid.lo jid.cc; \
then mv -f ".deps/jid.Tpo" ".deps/jid.Plo"; else rm -f ".deps/jid.Tpo"; exit 1; fi
../../talk/xmllite/qname.h: In constructor 'buzz::QName::Data::Data(const
std::string&, const std::string&)':
../../talk/xmllite/qname.h:77: warning: 'buzz::QName::Data::refcount_' will be
initialized after
../../talk/xmllite/qname.h:70: warning:   'std::string
buzz::QName::Data::namespace_'
../../talk/xmllite/qname.h:63: warning:   when initialized here
jid.cc: In static member function 'static std::string
buzz::Jid::prepNode(std::string, __gnu_cxx::__normal_iterator<const char*,
std::basic_string<char, std::char_traits<char>, std::allocator<char> > >,
__gnu_cxx::__normal_iterator<const char*, std::basic_string<char,
std::char_traits<char>, std::allocator<char> > >, bool*)':
jid.cc:256: warning: comparison is always true due to limited range of data type
jid.cc: In static member function 'static std::string
buzz::Jid::prepResource(std::string, __gnu_cxx::__normal_iterator<const char*,
std::basic_string<char, std::char_traits<char>, std::allocator<char> > >,
__gnu_cxx::__normal_iterator<const char*, std::basic_string<char,
std::char_traits<char>, std::allocator<char> > >, bool*)':
jid.cc:313: warning: comparison is always true due to limited range of data type
jid.cc: In static member function 'static void
buzz::Jid::prepDomainLabel(std::string, __gnu_cxx::__normal_iterator<const
char*, std::basic_string<char, std::char_traits<char>, std::allocator<char> > >,
__gnu_cxx::__normal_iterator<const char*, std::basic_string<char,
std::char_traits<char>, std::allocator<char> > >, std::string*, bool*)':
jid.cc:407: warning: comparison is always true due to limited range of data type
jid.cc: At global scope:
jid.cc:39: warning: 'int buzz::AsciiToLower(int)' defined but not used
if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..  -DPOSIX   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables   -MT saslmechanism.lo -MD -MP -MF
".deps/saslmechanism.Tpo" -c -o saslmechanism.lo saslmechanism.cc; \
then mv -f ".deps/saslmechanism.Tpo" ".deps/saslmechanism.Plo"; else rm -f
".deps/saslmechanism.Tpo"; exit 1; fi
../../talk/xmllite/qname.h: In constructor 'buzz::QName::Data::Data(const
std::string&, const std::string&)':
../../talk/xmllite/qname.h:77: warning: 'buzz::QName::Data::refcount_' will be
initialized after
../../talk/xmllite/qname.h:70: warning:   'std::string
buzz::QName::Data::namespace_'
../../talk/xmllite/qname.h:63: warning:   when initialized here
if /bin/sh ../../libtool --silent --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H
-I. -I. -I../..  -DPOSIX   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2
-fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables   -MT xmppclient.lo -MD -MP -MF
".deps/xmppclient.Tpo" -c -o xmppclient.lo xmppclient.cc; \
then mv -f ".deps/xmppclient.Tpo" ".deps/xmppclient.Plo"; else rm -f
".deps/xmppclient.Tpo"; exit 1; fi
../../talk/xmllite/qname.h: In constructor 'buzz::QName::Data::Data(const
std::string&, const std::string&)':
../../talk/xmllite/qname.h:77: warning: 'buzz::QName::Data::refcount_' will be
initialized after
../../talk/xmllite/qname.h:70: warning:   'std::string
buzz::QName::Data::namespace_'
../../talk/xmllite/qname.h:63: warning:   when initialized here
../../talk/xmpp/xmppengine.h: At global scope:
../../talk/xmpp/xmppengine.h:84: warning: 'class buzz::XmppOutputHandler' has
virtual functions but non-virtual destructor
../../talk/xmpp/xmppengine.h:101: warning: 'class buzz::XmppSessionHandler' has
virtual functions but non-virtual destructor
../../talk/xmpp/xmppengine.h:110: warning: 'class buzz::XmppStanzaHandler' has
virtual functions but non-virtual destructor
../../talk/xmpp/xmppengine.h:124: warning: 'class buzz::XmppIqHandler' has
virtual functions but non-virtual destructor
../../talk/base/sigslot.h: In instantiation of
'sigslot::_connection_base0<sigslot::single_threaded>':
../../talk/base/sigslot.h:1662:   instantiated from
'sigslot::_connection0<buzz::XmppClient::Private, sigslot::single_threaded>'
../../talk/base/sigslot.h:2098:   instantiated from 'void
sigslot::signal0<mt_policy>::connect(desttype*, void (desttype::*)()) [with
desttype = buzz::XmppClient::Private, mt_policy = sigslot::single_threaded]'
xmppclient.cc:98:   instantiated from here
../../talk/base/sigslot.h:305: warning: 'class
sigslot::_connection_base0<sigslot::single_threaded>' has virtual functions but
non-virtual destructor
../../talk/base/sigslot.h: In instantiation of
'sigslot::_connection0<buzz::XmppClient::Private, sigslot::single_threaded>':
../../talk/base/sigslot.h:2098:   instantiated from 'void
sigslot::signal0<mt_policy>::connect(desttype*, void (desttype::*)()) [with
desttype = buzz::XmppClient::Private, mt_policy = sigslot::single_threaded]'
xmppclient.cc:98:   instantiated from here
../../talk/base/sigslot.h:1662: warning: 'class
sigslot::_connection0<buzz::XmppClient::Private, sigslot::single_threaded>' has
virtual functions but non-virtual destructor
../../talk/base/sigslot.h: In instantiation of
'sigslot::_connection0<buzz::XmppClient, sigslot::single_threaded>':
../../talk/base/sigslot.h:2098:   instantiated from 'void
sigslot::signal0<mt_policy>::connect(desttype*, void (desttype::*)()) [with
desttype = buzz::XmppClient, mt_policy = sigslot::single_threaded]'
xmppclient.cc:165:   instantiated from here
../../talk/base/sigslot.h:1662: warning: 'class
sigslot::_connection0<buzz::XmppClient, sigslot::single_threaded>' has virtual
functions but non-virtual destructor
../../talk/base/sigslot.h: In instantiation of 'sigslot::_connection_base2<const
char*, int, sigslot::single_threaded>':
../../talk/base/sigslot.h:2260:   instantiated from 'void
sigslot::signal2<arg1_type, arg2_type, mt_policy>::operator()(arg1_type,
arg2_type) [with arg1_type = const char*, arg2_type = int, mt_policy =
sigslot::single_threaded]'
xmppclient.cc:305:   instantiated from here
../../talk/base/sigslot.h:325: warning: 'class sigslot::_connection_base2<const
char*, int, sigslot::single_threaded>' has virtual functions but non-virtual
destructor
../../talk/base/sigslot.h: In instantiation of
'sigslot::_connection_base1<buzz::XmppEngine::State, sigslot::single_threaded>':
../../talk/base/sigslot.h:2195:   instantiated from 'void
sigslot::signal1<arg1_type, mt_policy>::operator()(arg1_type) [with arg1_type =
buzz::XmppEngine::State, mt_policy = sigslot::single_threaded]'
xmppclient.cc:323:   instantiated from here
../../talk/base/sigslot.h:315: warning: 'class
sigslot::_connection_base1<buzz::XmppEngine::State, sigslot::single_threaded>'
has virtual functions but non-virtual destructor
../../talk/xmpp/saslplainmechanism.h: In member function 'virtual
buzz::XmlElement* buzz::SaslPlainMechanism::StartSaslAuth()':
../../talk/xmpp/saslplainmechanism.h:44: internal compiler error: in
coalesce_abnormal_edges, at tree-outof-ssa.c:646
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccPMLPYk.out file, please attach this to
your bugreport.
make[3]: *** [xmppclient.lo] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/libjingle-0.3.0/talk/xmpp'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/libjingle-0.3.0/talk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/libjingle-0.3.0'
make: *** [all] Error 2
Comment 1 Peter Robinson 2006-05-10 07:10:38 EDT
Created attachment 128841 [details]
Preprocessed source
Comment 2 Jakub Jelinek 2006-05-11 04:38:40 EDT
Tracking upstream.
Comment 3 Peter Robinson 2006-05-17 11:44:56 EDT
Hi Jakub,

I noticed this is fixed upstream, will this be pushed as a update to FC5 or will
it wait for the 4.1.1 release push, which according to the gcc site with a date
of May 15 must be due any moment now.

Cheers,
Pete

Note You need to log in before you can comment on or make changes to this bug.