Bug 191280 - Problem switching between init 1 and init 3
Problem switching between init 1 and init 3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: SysVinit (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 09:53 EDT by Daniel Yeisley
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 12:09:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Yeisley 2006-05-10 09:53:46 EDT
Description of problem:
I boot the system into runlevel 5.  From an xterm I do an init 1.  Then I do an 
init 3.  I see it go into runlevel 3, but it ends with "Starting HAL daemon:  [ 
OK ]" and I never get a login prompt.  

Version-Release number of selected component (if applicable):


How reproducible:
I was able to reproduce this on RHEL 4 U3 and Fedora Core 5.

Steps to Reproduce:
1.  Boot to X, login and open a terminal
2.  init 1
3.  at the prompt, init 3
  
Actual results:
Stuck on a screen that ends with "Starting HAL daemon:   [ OK ]"

Expected results:
should see a login prompt

Additional info:
Comment 1 Bill Nottingham 2006-05-10 12:09:06 EDT
Since you ran 'init 1' from X, your shell is on the tty that X ran from (usually
tty7 or tty8). When you run 'init 3', you remain on that tty. login is only
started on tty1-tty6 by default; hitting 'ctrl-<f1>' through 'ctrl-<f6>' should
cycle through the ttys.

Note You need to log in before you can comment on or make changes to this bug.