Bug 191339 - iostat always reports 100% disk util
iostat always reports 100% disk util
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-10 18:44 EDT by Hrunting Johnson
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 11:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 5.0.5-10.fc.test (34.71 KB, text/plain)
2006-05-15 08:38 EDT, Hrunting Johnson
no flags Details

  None (edit)
Description Hrunting Johnson 2006-05-10 18:44:34 EDT
Description of problem:
iostat always reports 100% disk util


Version-Release number of selected component (if applicable):
5.0.5-9.fc


How reproducible:
always


Steps to Reproduce:
1. run iostat
2.
3.
  
Actual results:
all disks show 100% disk utilization


Expected results:
disks show actual utilization


Additional info:
This problem started with the 2.6.16-x series of kernels.  I did not have this
problem with previous FC4 kernels, so maybe it gets reassigned to kernel managers.
Comment 1 Ivana Varekova 2006-05-12 04:25:38 EDT
I try to reproduce your problem with kernel 2.6.16-1.2096_FC5smp but I was
unsuccesfull. Please could you reproduce this problem with the latest version of
sysstat (sysstat-6.0.2-1.i386.rpm)? Which version of kernel do you use?
Comment 2 Hrunting Johnson 2006-05-12 09:27:04 EDT
The kernel I'm using is the latest version for FC4, 2.6.16-1.2096_FC4.  The
sysstat I'm using is the latest version of sysstat available for FC4.  Arch is
x86_64.  I can't install the FC5 package on FC4 because of library dependencies.
 Is there an updated version for FC4 somewhere?
Comment 3 Ivana Varekova 2006-05-15 08:27:32 EDT
Could you please try to reproduce your problem with the test version of sysstat
which is on 
http://people.redhat.com/varekova/sysstat-5.0.5-10.fc.test.x86_64.rpm
and attached its output here. 
Comment 4 Hrunting Johnson 2006-05-15 08:38:32 EDT
Created attachment 129053 [details]
Output from 5.0.5-10.fc.test

Requested output.
Comment 5 Ivana Varekova 2006-05-15 09:56:24 EDT
This seems to be kernel problem - sysstat count the right values from input data
produced by kernel (/proc/diskstats). 
Comment 6 Rolf Fokkens 2006-06-24 17:52:32 EDT
I've seen RHEL3 bug reports about the same, however that's a 2.4 kernel.

Look at this: sda and sdb show bogus avqqu-sz (361909.31). They're SATA, but hdd
is OK (IDE DVD-writer)

[rolf@home01 ~]$ iostat -x 1
Linux 2.6.16-1.2115_FC4 (home01.home.vertis.nl)         06/24/2006

avg-cpu:  %user   %nice    %sys %iowait   %idle
           3.15    0.03    0.85    0.76   95.22

Device:    rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s    rkB/s    wkB/s avgrq-sz
avgqu-sz   await  svctm  %util
hdd          2.15   0.00  0.06  0.00    8.81    0.00     4.40     0.00   158.42
    0.00   29.58  21.89   0.12
sda          0.15   8.11  1.10  2.50   44.68   84.96    22.34    42.48    36.00
    3.42   25.03 277.68  99.99
sdb          0.15   8.11  1.11  2.50   45.98   84.96    22.99    42.48    36.24
    3.41   24.36 276.74  99.99
md0          0.00   0.00  2.07  8.11   69.46   64.87    34.73    32.44    13.20
    0.00    0.00   0.00   0.00
md1          0.00   0.00  0.44  1.68   21.20   13.45    10.60     6.73    16.30
    0.00    0.00   0.00   0.00
dm-0         0.00   0.00  2.51  9.73   90.62   77.81    45.31    38.90    13.77
    3.90  318.45   0.91   1.12
dm-1         0.00   0.00  0.00  0.06    0.03    0.51     0.02     0.26     8.00
    0.02  260.50   0.28   0.00

avg-cpu:  %user   %nice    %sys %iowait   %idle
           1.00    0.00    1.00   98.00    0.00

Device:    rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s    rkB/s    wkB/s avgrq-sz
avgqu-sz   await  svctm  %util
hdd        142.00   0.00 48.00  0.00  760.00    0.00   380.00     0.00    15.83
    0.84   16.92  17.50  84.00
sda          2.00   0.00 17.00  4.00  440.00   32.00   220.00    16.00    22.48
361909.31   22.67  47.81 100.40
sdb          2.00   0.00 36.00  4.00  512.00   32.00   256.00    16.00    13.60
361909.32   12.00  25.10 100.40
md0          0.00   0.00 56.00  0.00  944.00    0.00   472.00     0.00    16.86
    0.00    0.00   0.00   0.00
md1          0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00     0.00
    0.00    0.00   0.00   0.00
dm-0         0.00   0.00 56.00  0.00  944.00    0.00   472.00     0.00    16.86
    0.39    7.00   3.71  20.80
dm-1         0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00     0.00
    0.00    0.00   0.00   0.00


[rolf@home01 ~]$
Comment 7 Rolf Fokkens 2006-06-25 13:37:07 EDT
I withdraw the last comment: kernel-2.6.17-1.2139_FC4 solves the matter.

Note You need to log in before you can comment on or make changes to this bug.