Bug 191355 - ifup busted
ifup busted
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 00:57 EDT by Gene Heskett
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 16:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Heskett 2006-05-11 00:57:58 EDT
Description of problem:

Trying to hook up a broadcom 4318 radio in an HP dv5320us laptop, running a
fully uptodate FC5, to an unkeyed, wide open motel 802-11g lashup.  Cannot get
rid of the iwconfig setting showing the key is enabled and specified even though
ifcfg-wlan0 has a line KEY=off in it.  One must move the keys-wlan0 file to
keez-wlan0 to prevent it from being found when an ifup wlan0 is executed.

(I might add that this is using ndiswrapper, and that with a 128 bit key setup
at home, works just fine to an old wap11 access point, so I know the radio does
work.)

Got that figured out, and I also have the ESSID set in this same ifcfg-wlan0
file, but its also being ignored, I can't set it either from the command line
with an 'iwconfig wlan0 essid "Name of Hosts ESSID"' or via adding that line to
ifcfg-wlan0.


Version-Release number of selected component (if applicable):
[root@diablo network-scripts]# rpm -q initscripts
initscripts-8.31.2-1

How reproducible:
Make a valid keys-wlan0 file, it overrides the KEY= choices in the ifcfg files.

Steps to Reproduce:
1.iwconfig wlan0 key off
2. check with an iwconfig wlan0, keys and encryption will show as off.
3. do 'ifup wlan0'
4. check iwconfig output after the ifup fails, it will be all setup again IF the
keys-wlan0 file exists.
  
Actual results:
see above

Expected results:
see above.  One MUST mv the keys-wlan0 file to stop it. If its valid, then:
[root@diablo network-scripts]# iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"diablo.coyote.den"
          Mode:Managed  Frequency:2.457 GHz  Access Point: Not-Associated
          Bit Rate=54 Mb/s   Tx-Power:24 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:4495-9916-B297-EB54-9C26-9592-6F   Security mode:restricted
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Additional info:

This won't allow it to connect, but its at least a step in the right direction.

I just tried to reset it with system-config-network, and that puppy found a key
file and regenerated a keys-wlan0 file AGAIN after I'd mv'd it out of the way.

And don't even mention NetworkManager, that things been busted since forever and
no one appears to be working on it.  Messages on the fedora list seem to agree
that no one else can make it work either.  It should be nuked.
Comment 1 Bill Nottingham 2006-05-16 16:10:46 EDT
Thank you for the bug report. However, Fedora Project only ships and maintains
Free and Open Source software.  Issues such as these are beyond the control of
Fedora developers. We suggest using the included bcm43xxx driver; ndiswrapper is
not something we can support.

Setting status to "CANTFIX" (unsupported).

Note You need to log in before you can comment on or make changes to this bug.