Bug 191431 - Need immediate edits to 2-way prop email
Need immediate edits to 2-way prop email
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other (Show other bugs)
RHN Stable
All Linux
high Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Steve Salevan
:
Depends On: 188911
Blocks: 171832
  Show dependency treegraph
 
Reported: 2006-05-11 17:27 EDT by Teresa Wilkerson
Modified: 2016-04-18 02:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 19:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Revised content for Login Creation email (Two way prop) (6.26 KB, application/vnd.sun.xml.writer)
2006-05-11 17:27 EDT, Teresa Wilkerson
no flags Details
This is the content that should replace the existing 2-way prop email. (6.25 KB, application/vnd.sun.xml.writer)
2006-05-19 11:01 EDT, Teresa Wilkerson
no flags Details
New content for 2-way prop email. (6.43 KB, application/vnd.sun.xml.writer)
2006-06-01 17:58 EDT, Teresa Wilkerson
no flags Details
Final content for 2-way prop email June 14 2006. (6.31 KB, application/vnd.sun.xml.writer)
2006-06-14 13:44 EDT, Teresa Wilkerson
no flags Details
Revised content for login creation email June 28 with intl links (6.34 KB, application/vnd.sun.xml.writer)
2006-06-28 14:53 EDT, Teresa Wilkerson
no flags Details

  None (edit)
Description Teresa Wilkerson 2006-05-11 17:27:17 EDT
Description of problem:
The current messaging in the 2-way prop (login creation request) email is
unclear.  Because more and more customers are being directly entitled through
OCS, this notice is going out to more customers and is going beyond North America.

I would like to phase in other enhancements over the next few weeks as well, so
I would like to talk about how this and future changes can be managed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Teresa Wilkerson 2006-05-11 17:27:17 EDT
Created attachment 128918 [details]
Revised content for Login Creation email (Two way prop)
Comment 2 Teresa Wilkerson 2006-05-19 11:01:14 EDT
Created attachment 129604 [details]
This is the content that should replace the existing 2-way prop email.  

This content contains minor edits to the original text I attached for this bug.
 Please use this revision to make the text changes.
Comment 3 Teresa Wilkerson 2006-06-01 17:58:25 EDT
Created attachment 130377 [details]
New content for 2-way prop email.

New content for 2-way prop email.
Comment 7 Jesus M. Rodriguez 2006-06-02 16:34:09 EDT
TEST PLAN
----------
1) Use the test plan for the bug #170284 to get email sent.
2) verify the email matches the content in Comment #5, except the
   Customer Name and Account Number should match that of the user
   you specified in Step 1.
Comment 8 Teresa Wilkerson 2006-06-14 13:44:30 EDT
Created attachment 130889 [details]
Final content for 2-way prop email June 14 2006.
Comment 9 Jesus M. Rodriguez 2006-06-14 17:18:23 EDT
Moving to ON_QA
Comment 10 Steve Salevan 2006-06-15 12:24:10 EDT
Taking care of this issue at the moment...  should have an update soon.
Comment 12 Jesus M. Rodriguez 2006-06-19 18:41:23 EDT
Moving to ON_QA
Comment 13 Timo Trinks 2006-06-19 19:00:14 EDT
Hi!

Resource key email.newuser.bala.footer has been adapted exactly to the requested
German value: "Für zusätzliche Informationen in deutscher Sprache, besuchen Sie
bitte unsere Website:"

Regards,

Timo
Comment 14 Steve Salevan 2006-06-26 13:30:02 EDT
Taskomatic on any RHN hosted environment is in a flaky state.  Since, after
several iterations of the test plan in bug #170284 to generate an email, no
emails could be generated, I'm waiting until Taskomatic becomes available again
before testing out this issue.
Comment 15 Teresa Wilkerson 2006-06-28 14:53:06 EDT
Created attachment 131690 [details]
Revised content for login creation email June 28 with intl links
Comment 16 Mike McCune 2006-06-28 17:05:51 EDT
more content required.  moving back to ASSIGNED.
Comment 17 Jesus M. Rodriguez 2006-07-03 17:00:42 EDT
Added french text, pending translation from brisbane.
Comment 18 Jesus M. Rodriguez 2006-07-10 14:53:17 EDT
Moving to ON_QA
Comment 19 Steve Salevan 2006-07-10 17:46:02 EDT
I am moving this bug to FAILS_QA, because the test plan in bug #170284 that
we're using will not generate the appropriate e-mail.  I have tried the
following techniques:

1.  I created a fresh account, populating its oracle_customer_id number in
web_contact as shown by kganong's comment in bug #170284.  I then added a row as
described by the test plan into web_customer_notification as described for the
test plan.  I ensured that in all cases, the email address it pointed to was
ssalevan@rhn.redhat.com, which properly directed emails to me in a different
Taskomatic-related bug.

2.  I found an existing account, changed its email address to
ssalevan@rhn.redhat.com, and used all its relevant information (org_id, etc.) to
populate a new row in web_customer_notification.

In both cases, I tailed the rhn_taskomatic.log file, and each time that the
SummaryPopulation task was run, this traceback would be given near its completion:

[2006-07-10 17:42:59,629] ERROR com.redhat.rhn.task.SummaryPopulation -
ORA-00001: unique constraint (RHN.RHN_DSQUEUE_OID_UQ) violated

com.redhat.rhn.common.db.ConstraintViolationException: ORA-00001: unique
constraint (RHN.RHN_DSQUEUE_OID_UQ) violated

        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java(Compiled Code))
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java(Inlined
Compiled Code))
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java(Compiled Code))
        at
oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java(Compiled
Code))
        at
oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java(Compiled
Code))
        at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java(Compiled
Code))
        at
oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java(Compiled
Code))
        at
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java(Compiled
Code))
        at
com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java(Compiled
Code))
        at
com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java(Inlined
Compiled Code))
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java(Compiled
Code))
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java(Inlined
Compiled Code))
        at
com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java(Inlined
Compiled Code))
        at
com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java(Compiled
Code))
        at
com.redhat.rhn.task.SummaryPopulation.enqueueOrg(SummaryPopulation.java:104)
        at com.redhat.rhn.task.SummaryPopulation.run(SummaryPopulation.java:68)
        at
com.redhat.rhn.task.SingleThreadedTask.execute(SingleThreadedTask.java:46)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
        at
org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java(Compiled
Code))
Caused by: java.sql.SQLException: ORA-00001: unique constraint
(RHN.RHN_DSQUEUE_OID_UQ) violated

        ... 20 more
[2006-07-10 17:42:59,632] ERROR com.redhat.rhn.taskomatic.SchedulerKernel -
org.quartz.JobExecutionException:
com.redhat.rhn.common.db.ConstraintViolationException: ORA-00001: unique
constraint (RHN.RHN_DSQUEUE_OID_UQ) violated
 [See nested exception: com.redhat.rhn.common.db.ConstraintViolationException:
ORA-00001: unique constraint (RHN.RHN_DSQUEUE_OID_UQ) violated

After waiting a half hour, no emails were sent, so I've got to think that
there's something wrong with the actual test plan now that taskomatic's running
on WebQA.  As a result, I'm moving this to FAILS_QA for further consideration.
Comment 20 Jesus M. Rodriguez 2006-07-10 20:36:08 EDT
This looks like we have two seperate problems.  One is SummaryPopulation, the
other is pushed users.
Comment 21 Jesus M. Rodriguez 2006-07-10 21:06:43 EDT
The DailySummary queue error is not caused by PushedUsers and I have opened a
separate bug for that, see bug #198314.

The problem with PushedUsers was a typo in the query that looks for users
to email.
Comment 22 Steve Salevan 2006-07-11 10:58:01 EDT
Now that that SummaryPopulation bug is fixed, following the test plan now
(finally) produces a 2-way prop email in the appropriate fashion, complete with
the appropriate French and German strings and the correct style of link to the
RHN site.  I am now moving this bug to VERIFIED.
Comment 23 Beth Nackashi 2006-07-19 19:49:19 EDT
closing - currentrelease

Note You need to log in before you can comment on or make changes to this bug.