Bug 191433 - Add -devel and -libs sub-packages
Add -devel and -libs sub-packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 17:55 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 7.1.2-1.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 17:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec patch to add -devel and -libs sub-packages. (2.40 KB, patch)
2006-05-11 17:55 EDT, Orion Poplawski
no flags Details | Diff
Patch to lam.spec to update to 7.1.2 and create -devel and -libs pacakges (3.55 KB, patch)
2006-05-19 17:20 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2006-05-11 17:55:56 EDT
It is common to build MPI libraries with various Fortan and other compilers. 
The attached patch adds -devel and -libs sub-packages.  This makes it easier to
build  other lam rpms based on this spec with different compilers and install
the needed libraries in parallel on the various nodes.

To build for a different compiler, e.g. ifort, change:

< Name: lam
---
> Name: lam-ifort

> Provides: lam

< %setup -q
---
> %setup -q -n lam-%{version}

> FFLAGS="-axP -fPIC"
70c56,57
< FFLAGS="$RPM_OPT_FLAGS -fPIC"
---
> %else
> FFLAGS="-axKNBP"
73c60
< export FC=f95
---
> export FC=ifort
Comment 1 Orion Poplawski 2006-05-11 17:55:56 EDT
Created attachment 128919 [details]
spec patch to add -devel and -libs sub-packages.
Comment 2 Orion Poplawski 2006-05-19 17:20:35 EDT
Created attachment 129631 [details]
Patch to lam.spec to update to 7.1.2 and create -devel and -libs pacakges

Looks like there is some life upstream.  The attached patch updates to 7.1.2 as
well as splits the package.  Probably should also move the compiler wrappers to
the -devel package.
Comment 3 Jason Vas Dias 2006-06-14 16:44:53 EDT
Fixed with lam-7.1.2, now in rawhide and FC-5 Updates/Testing.
Comment 4 Fedora Update System 2006-07-06 23:44:26 EDT
lam-7.1.2-1.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.