Bug 191447 - selinux ate my X font server.
selinux ate my X font server.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-11 22:18 EDT by Dave Jones
Modified: 2015-01-04 17:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-15 21:20:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-05-11 22:18:07 EDT
X won't start up with the latest rawhide, as the font server gets prevented from
starting..

type=AVC msg=audit(1147399778.490:11): avc:  denied  { getattr } for  pid=2265
comm="xfs" name=".font-unix" dev=dm-0 ino=17432587
scontext=system_u:system_r:xfs_t:s0 tcontext=system_u:object_r:initrc_tmp_t:s0
tclass=dir
type=AVC msg=audit(1147399951.366:22): avc:  denied  { getattr } for  pid=2761
comm="xfs" name=".font-unix" dev=dm-0 ino=17432587
scontext=user_u:system_r:xfs_t:s0 tcontext=user_u:object_r:initrc_tmp_t:s0
tclass=dir
type=AVC msg=audit(1147399989.671:24): avc:  denied  { getattr } for  pid=2937
comm="xfs" name=".font-unix" dev=dm-0 ino=17432579
scontext=user_u:system_r:xfs_t:s0 tcontext=user_u:object_r:initrc_tmp_t:s0
tclass=dir
type=AVC msg=audit(1147399989.671:25): avc:  denied  { search } for  pid=2937
comm="xfs" name=".font-unix" dev=dm-0 ino=17432579
scontext=user_u:system_r:xfs_t:s0 tcontext=user_u:object_r:initrc_tmp_t:s0
tclass=dir
type=AVC msg=audit(1147399989.671:26): avc:  denied  { write } for  pid=2937
comm="xfs" name=".font-unix" dev=dm-0 ino=17432579
scontext=user_u:system_r:xfs_t:s0 tcontext=user_u:object_r:initrc_tmp_t:s0
tclass=dir
type=AVC msg=audit(1147399989.671:26): avc:  denied  { add_name } for  pid=2937
comm="xfs" name="fs7100" scontext=user_u:system_r:xfs_t:s0
tcontext=user_u:object_r:initrc_tmp_t:s0 tclass=dir
type=AVC msg=audit(1147399989.671:26): avc:  denied  { create } for  pid=2937
comm="xfs" name="fs7100" scontext=user_u:system_r:xfs_t:s0
tcontext=user_u:object_r:initrc_tmp_t:s0 tclass=sock_file
Comment 1 Daniel Walsh 2006-05-12 11:25:01 EDT
What does 

matchpathcon  /tmp/.font-unix

Show?
Comment 2 Dave Jones 2006-05-12 22:48:49 EDT
file_contexts:  invalid context system_u:object_r:xfs_tmp_t:s0
matchpathcon:  matchpathcon(/tmp/.font-unix) failed
Comment 3 Daniel Walsh 2006-06-15 21:38:34 EDT
Are you still seeing this problem?  Looks like the /tmp/.font-unix directory was
mislabeled.  Should be labeled xfs_tmp_t


Note You need to log in before you can comment on or make changes to this bug.