Bug 191456 - stellarium-0.8.0-2.fc4 package broken: doesn't install properly
stellarium-0.8.0-2.fc4 package broken: doesn't install properly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
4
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 02:21 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: stellarium-0.8.0-3.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 22:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-05-12 02:21:40 EDT
Description of problem:
the recent stellarium package is broken and fails to install properly, even
though the application runs many files are missing.  Also rpm reports it as not
being installed at all.

Version-Release number of selected component (if applicable):
stellarium-0.8.0-2.fc4

How reproducible:
Every time.

Steps to Reproduce:
1. yum upgrade
2. stellarium

Actual results:
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for stellarium to pack into transaction set.
stellarium-0.8.0-2.fc4.i3 100% |=========================|  45 kB    00:01
---> Package stellarium.i386 0:0.8.0-2.fc4 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 stellarium              i386       0.8.0-2.fc4      extras            5.0 M

Transaction Summary
=============================================================================
Install      1 Package(s)
Update       0 Package(s)
Remove       0 Package(s)
Total download size: 5.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): stellarium-0.8.0-2 100% |=========================| 5.0 MB    01:44
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: stellarium                   ######################### [1/1]
error: unpacking of archive failed on file
/usr/share/stellarium/textures/constellation-art/hercules.png;4463fdbc: cpio: read

Installed: stellarium.i386 0:0.8.0-2.fc4
Complete!

$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.8.0 - http://www.stellarium.org ]
[ Copyright (C) 2000-2005 Fabien Chereau et al         ]
 -------------------------------------------------------
Attempting to use an existing older config file.
Application locale is system
WARNING : Can't find texture file /usr/share/stellarium/textures/sun.png!
WARNING : Can't find texture file /usr/share/stellarium/textures/halo.png!
WARNING : Can't find texture file /usr/share/stellarium/textures/mercury.png!

Expected results:
No error should have been produced and

Additional info:
Because the package was broken, rpm doesn't think it is installed:

$ rpm -q stellarium
package stellarium is not installed.

I also tried removing it and re-installing: same problem.
Comment 1 stephen 2006-05-13 13:02:21 EDT
I have the same problem on update.  I uninstalled it and installed it fresh,
then I have more errors and missing files.  RPM doesn't detect the install.

When yum is installling the update, the hashes only go about halfway before it
errors out, but yum still fills the line of hashes to full as it if was
completed.  No cleanup stage is performed by yum.u
Comment 2 Jochen Schmitt 2006-05-14 14:00:09 EDT
I have found out, that the binary RPM for FC-4 have nopt the right file size and
may be demanged.

So I have reinitiate a build for FC-4. I hope the rebuilt RPM will be available
in the next days.

Sorry for any inconvinience.
Comment 3 Alex Lancaster 2006-05-16 06:05:56 EDT
I think(In reply to comment #2)
> I have found out, that the binary RPM for FC-4 have nopt the right file size and
> may be demanged.
> 
> So I have reinitiate a build for FC-4. I hope the rebuilt RPM will be available
> in the next days.

I think you need to bump up the release number, because the new RPM didn't get
included in the push. 0.8.0-2.fc4 available now was built on May 8, rather than
the fixed May 14 or so build. 
Comment 4 Jochen Schmitt 2006-05-16 11:34:25 EDT
Thank you for your hint. I have bump the release number and reinitiate a new build.

I Hope the binary package will be available in the next days.
Comment 5 Alex Lancaster 2006-05-17 22:00:08 EDT
Package is updated and seems to work for me.  Closing bug.

Note You need to log in before you can comment on or make changes to this bug.