Bug 191459 - mpage requires extra fonts than needed
mpage requires extra fonts than needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mpage (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 03:31 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.5.4-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-12 07:05:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to strict font requirement in ps file (2.40 KB, patch)
2006-05-12 03:31 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2006-05-12 03:31:04 EDT
Description of problem:
mpage requires extra fonts than needed.

When I was glancing at fedora-list, I found the complaint about current 
mpage against fc5. Please see the detail at
https://www.redhat.com/archives/fedora-list/2006-May/msg02281.html .
I think this complaint is reasonable.

This is because the ps file output by mpage requires extra fonts than is 
really needed and then browsing this ps file requires nosafer mode of gs,
while gv invokes gs in safer mode by default.

Version-Release number of selected component (if applicable):
mpage-2.5.4-6.1

How reproducible:
100%

Steps to Reproduce:
1. ls -al | mpage > foo.ps
2. gs -dSAFER -sDEVICE=x11 foo.ps
3.
  
Actual results:
foo.ps cannot be seen by gs.

Expected results:
gs can browse foo.ps

Additional info:
I attached a proposal patch which restricts the fonts required in the
ps file output by mpage.
Comment 1 Mamoru TASAKA 2006-05-12 03:31:04 EDT
Created attachment 128928 [details]
Patch to strict font requirement in ps file
Comment 2 Jitka Kozana 2006-05-12 07:05:48 EDT
Thank you for your information.
I applied your patch, the problem should be now fixed in version 2.5.4-7.

Note You need to log in before you can comment on or make changes to this bug.