Bug 191469 - upgrade to gnome-music-applet 0.9.2
upgrade to gnome-music-applet 0.9.2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-applet-music (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
http://web.ics.purdue.edu/~kuliniew/m...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 05:57 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 23:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-05-12 05:57:38 EDT
Description of problem:
gnome-music-applet is now at version 0.9.1:

http://web.ics.purdue.edu/~kuliniew/music-applet/

FC-4 only has 0.9.0

Version-Release number of selected component (if applicable):
gnome-music-applet-0.9.0-1.fc4
Comment 1 Alex Lancaster 2006-06-01 20:33:38 EDT
Ping?  It's been over two weeks.
Comment 2 Alex Lancaster 2006-07-05 18:06:11 EDT
Ping?  It's been almost 2 months.
Comment 3 Alex Lancaster 2006-07-05 18:08:15 EDT
It's now at 0.9.2.
Comment 4 Alex Lancaster 2006-08-28 15:26:42 EDT
Looks like the maintainer (Ignacio) vanished and this is now listed under
orphaned packages:

http://fedoraproject.org/wiki/Extras/OrphanedPackages
Comment 5 Peter Gordon 2006-08-28 23:38:03 EDT
I use this quite a bit, so I'll take it over if no one objects by the end of the
week as mentioned in the ML thread on fedora-extras-list.

Alex: If/When I do take this, I'll attempt to get this updated just as soon the
mass FC6 rebuilding stuff is through. I'll definitely need assistance with
FC4-specific testing/bug squashing. though, as I'm on FC5. :)
Comment 6 Alex Lancaster 2006-08-29 04:06:35 EDT
(In reply to comment #5)
> I use this quite a bit, so I'll take it over if no one objects by the end of the
> week as mentioned in the ML thread on fedora-extras-list.

Excellent.

> Alex: If/When I do take this, I'll attempt to get this updated just as soon the
> mass FC6 rebuilding stuff is through. I'll definitely need assistance with
> FC4-specific testing/bug squashing. though, as I'm on FC5. :)

I'm on FC-5 now, too.  Although I still have an FC-4 box.  

FC-4 only has rhythmbox-0.8.8-2 and it's unclear whether gnome-music-applet will
work with any of the rhythmbox 0.8 series (it definitely won't work with
rhythmbox 0.9.0 or 0.9.1 according to
http://www.kuliniewicz.org/music-applet/faq.html).  rhythmbox-0.8.8 will
probably continue to work with the old gnome-applet-rhythmbox.
I can always test the new version to see if it works with the old 0.8.8 rhythmbox.

Comment 7 Peter Gordon 2006-08-29 10:27:21 EDT
(In reply to comment #6)
> FC-4 only has rhythmbox-0.8.8-2 and it's unclear whether gnome-music-applet will
> work with any of the rhythmbox 0.8 series (it definitely won't work with
> rhythmbox 0.9.0 or 0.9.1 according to
> http://www.kuliniewicz.org/music-applet/faq.html).  rhythmbox-0.8.8 will
> probably continue to work with the old gnome-applet-rhythmbox.
> I can always test the new version to see if it works with the old 0.8.8 rhythmbox.

Accoring to that FAQ, it should work fine with the older Rhythmbox 0.8.x just
fine via Bonobo (instead of using D-Bus as for the 0.9.x stuff). I guess we'll
cross that bridge when we come to it, as the saying goes. :)
Comment 8 Peter Gordon 2006-08-29 22:54:30 EDT
A small note to myself and others that Banshee support in 0.9.2 is currently
non-functional due to errors in dbus-sharp which make Banshee unable to connect
to your D-Bus session. The patch from Christian Krause in bug #187452 appears to
fix that for me. Hopefully that is accepted and a new release made for this soon. :)
Comment 9 Alex Lancaster 2006-09-03 07:30:17 EDT
Ping?  Surely this can be officially orphaned now?  I noticed that Brian Pepple
picked up some of Ignacio's other packages already, so I imagine that Peter
Gordon should be able to go ahead and adopt this package.
Comment 10 Peter Gordon 2006-09-03 18:02:33 EDT
(Taking this and adding Ignacio to the CC: list.)
Comment 11 Peter Gordon 2006-09-03 22:06:53 EDT
Well, it appears as though Ignacio was able to update this in CVS, but never
pushed it through the build system. I've got Mock currently grabbing an FC-4
buildroot, and will make sure it builds fine there. Once I see that it builds
ok, I'll enqueue that on the build system to be pushed as an update.
Comment 12 Peter Gordon 2006-09-03 23:27:42 EDT
I just finished churning 0.9.2-2.fc4 through the build system, so it should hit
your favorite mirror soon. Thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.