Bug 191471 - system-config-printer complains on startup
system-config-printer complains on startup
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 06:24 EDT by Mike Olsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 12:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Olsen 2006-05-12 06:24:42 EDT
Description of problem:
When the command:
   system-config-printer
is issued, the following output is recieved on stderr:
########################################################################3
No match for USB device:
  mfr "hp"
  model "officejet 4200 series"
  desc ""
  cmdset "LDL,MLC,PML,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Guessing ID HP-OfficeJet_4200 for match
##############################################################################

Version-Release number of selected component (if applicable):
foomatic-3.0.2-33.3
hplip-0.9.8-6
hpijs-0.9.8-6

How reproducible:
Always happens

Steps to Reproduce:
1.Issue the command system-config-printer

  
Actual results:
No match for USB device:
  mfr "hp"
  model "officejet 4200 series"
  desc ""
  cmdset "LDL,MLC,PML,DYN"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Guessing ID HP-OfficeJet_4200 for match


Expected results:


Additional info:
I suspect this is due to hpijs and hplip both being installed (I just upgraded
to fc5, and was using the hpijs, now attempting to use hplip).  When I removed
hpijs package, the error goes away.  I am assuming that hplip should REPLACE
hpijs, and thus I should only have one of them installed.
Comment 1 Mike Olsen 2006-05-12 06:37:04 EDT
Correction for Additional info: This error does NOT go away after I did rpm -e
hpijs.  Now, I get the additional message:

This driver requires Hewlett Packard's hpijs driver (available in the hpijs
package) which does not appear to be installed.
Do you wish to use it anyway?

I'd appreciate some guidance on whether I should find and reinstall hpijs, or if
hplip should be all I need...

Thanks
Comment 2 Tim Waugh 2006-05-12 06:52:26 EDT
Both packages should be installed.

The error message is entirely harmless: system-config-printer correctly guesses
the right foomatic ID for the printer.

I will fix foomatic so that system-config-printer no longer has to guess. 
Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.