Bug 191480 - rpm-4.2.2-24 spec should have BuildRequires: elfutils-devel >= 0.112
rpm-4.2.2-24 spec should have BuildRequires: elfutils-devel >= 0.112
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 08:42 EDT by Kir Kolyshkin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 09:44:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kir Kolyshkin 2006-05-12 08:42:58 EDT
rpm-4.2.2 (both rpm-4.4.2-15.2 from fc5 and rpm-4.4.2-24 from development) uses
function gelf_offscn from elfutils-libs. The function has appeared in
elfutils-0.112, as NEWS from elfutils tarball says.

Thus, rpm.spec should be fixed like this:
-BuildRequires: elfutils-libelf
-BuildRequires: elfutils-devel
+BuildRequires: elfutils-devel >= 0.112

Note that I have removed elfutils-libelf requirement since elfutils-devel
requires elfutils-libelf-devel which in turn requires elfutils-libelf, so this
line is redundant.
Comment 1 Kir Kolyshkin 2006-05-12 08:46:26 EDT
Hmm sorry I'm not sure I am right here...let me recheck it again.
Comment 2 Kir Kolyshkin 2006-05-12 09:53:29 EDT
OK I found out that the above is true only for development version, i.e. 4.2.2-24.

Version and Summary fields changed accordingly.
Comment 3 Kir Kolyshkin 2006-05-12 09:54:16 EDT
And this is due to rpm-4.4.2-devel-autodep.patch
Comment 4 Paul Nasrat 2006-06-30 09:44:09 EDT
Should be done in rawhide.

Note You need to log in before you can comment on or make changes to this bug.