Bug 191551 - Oowriter crashed
Oowriter crashed
Status: CLOSED DUPLICATE of bug 189577
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-12 16:28 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 04:49:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-05-12 16:28:07 EDT
Description of problem:
I tried to open a .doc attachment from thunderbird, and I got this message:


Video Driver is probably: vesa i810
Desktop is: GNOME
libgcj version is: libgcj-4.1.0-3
kernel is: Linux 2.6.16-1.2111_FC5smp #1 SMP Thu May 4 21:35:09 EDT 2006 i686
i686 i386
OpenOffice.org core rpm version is: openoffice.org-core-2.0.2-5.9.2
accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
0x4037680: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e680
0x4037ec0: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1eec0
0xab9420:  + 0x420 (__kernel_sigreturn + 0x0)
0xb006e3: /lib/libc.so.6 + 0x296e3 (abort + 0x103)
0x15b8395: /lib/libdbus-1.so.2 + 0x55395
0x15a21e7: /lib/libdbus-1.so.2 + 0x3f1e7
0x15769c5: /lib/libdbus-1.so.2 + 0x139c5 (dbus_connection_get_dispatch_status +
0xb5)
0x21f4159: /usr/lib/libdbus-glib-1.so.2 + 0x8159
0x2b0b8e2: /usr/lib/libglib-2.0.so.0 + 0x278e2 (g_main_context_prepare + 0x182)
0x2b0c0b5: /usr/lib/libglib-2.0.so.0 + 0x280b5
0x2b0c955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe0fa01: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14a01
0xf4d291: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x43291
(X11SalInstance::Yield(unsigned char) + 0x27)
0x4a09866: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a866
(Application::Yield() + 0x48)
0x4af7825: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x178825
(Dialog::Execute() + 0x14f)
0x7682e64: /usr/lib/openoffice.org2.0/program/libuui680li.so + 0xae64
0x7683249: /usr/lib/openoffice.org2.0/program/libuui680li.so + 0xb249
0x7687164: /usr/lib/openoffice.org2.0/program/libuui680li.so + 0xf164
0x7681222: /usr/lib/openoffice.org2.0/program/libuui680li.so + 0x9222
0x4238892: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x6b892
0x4359ac7: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x29ac7
0x4359bca: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x29bca
0x4359bf6: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x29bf6
(ucbhelper::InterceptedInteraction::handle(com::sun::star::uno::Reference<com::sun::star::task::XInteractionRequest>
const&) + 0xe)
0x4378d82: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x48d82
(ucbhelper::cancelCommandExecution(com::sun::star::ucb::IOErrorCode,
com::sun::star::uno::Sequence<com::sun::star::uno::Any> const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&,
rtl::OUString const&,
com::sun::star::uno::Reference<com::sun::star::ucb::XCommandProcessor> const&) +
0x9a)
0x6589c3b: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x2ec3b
0x657b824: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x20824
0x6568493: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0xd493
0x656bd2f: /usr/lib/openoffice.org2.0/program/libucpfile1.so + 0x10d2f
0x434e6b5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1e6b5
0x434f9c3: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1f9c3
(ucb::Content::getPropertyValuesInterface(com::sun::star::uno::Sequence<rtl::OUString>
const&) + 0xaf)
0x43504f4: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x204f4
(ucb::Content::getPropertyValues(com::sun::star::uno::Sequence<rtl::OUString>
const&) + 0x24)
0x4350761: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x20761
(ucb::Content::getPropertyValue(rtl::OUString const&) + 0x43)
0x43507d5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x207d5
(ucb::Content::isDocument() + 0x33)
0x4350ae8: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x20ae8
(ucb::Content::openWriteableStream() + 0x1c)
0x4236e82: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x69e82
0x4237554: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x6a554
(comphelper::MediaDescriptor::addInputStream() + 0x198)
0x1620582: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x20582
0x1620618: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x20618
0x1620f6e: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x20f6e
0x16223ce: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x223ce
0x6486ed2: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xe9ed2
0x6489528: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xec528
0x63e1cf4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x44cf4
0x64c5243: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x128243
0x64c5849: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x128849
0x64c5bb5: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x128bb5
0x64c68da: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1298da
0x64c6bed: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x129bed
0x64e3dad: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x146dad
0x665950a: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2950a
(desktop::Desktop::OpenClients() + 0xade)
0x6659945: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x29945
(desktop::Desktop::OpenClients_Impl(void*) + 0x35)
0x6659994: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x29994
(desktop::Desktop::LinkStubOpenClients_Impl(void*, void*) + 0x1a)
0x4a022f6: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x832f6
0x4b50c1e: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d1c1e
0xf286b6: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1e6b6
0xf4c44e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x4244e
(SalDisplay::DispatchInternalEvent() + 0x64)
0xe0fb5a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14b5a
0x2b077a1: /usr/lib/libglib-2.0.so.0 + 0x237a1
0x2b0915d: /usr/lib/libglib-2.0.so.0 + 0x2515d (g_main_context_dispatch + 0x16d)
0x2b0c3ef: /usr/lib/libglib-2.0.so.0 + 0x283ef
0x2b0c955: /usr/lib/libglib-2.0.so.0 + 0x28955 (g_main_context_iteration + 0x65)
0xe0fa01: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x14a01
0xf4d291: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x43291
(X11SalInstance::Yield(unsigned char) + 0x27)
0x4a09866: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a866
(Application::Yield() + 0x48)
0x4a098ea: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8a8ea
(Application::Execute() + 0x26)
0x66580bb: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x280bb
(desktop::Desktop::Main() + 0x15af)
0x4a0d956: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e956
0x4a0da09: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ea09 (SVMain()
+ 0x2b)
0x6650bf3: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20bf3 (sal_main
+ 0x57)
0x6650c3f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x20c3f (main + 0x27)
0xaec7e4: /lib/libc.so.6 + 0x157e4 (__libc_start_main + 0xdc)
0x80484b1: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4b1


This is not repeatable. When I tired to run oowriter on the same file:

The following message appeared on the console:

(swriter.bin:3025): GnomePrintCupsPlugin-WARNING **: iconv does not support ppd
character encoding: ISOLatin1, trying CSISOLatin1

And a dialog box popped up saying: 
"/tmp/Korea, Republic.doc does not exist."
Followed by another one saying 
"/tmp/Motolola UCB Visit Agenda.doc does not exist."

After which, the file opened up.
Comment 1 Caolan McNamara 2006-05-15 04:49:23 EDT
Going to have to come up with an alternative workaround for this

*** This bug has been marked as a duplicate of 189577 ***

Note You need to log in before you can comment on or make changes to this bug.