Bug 191612 - Missing Build Requires for libX11-devel and libX11
Missing Build Requires for libX11-devel and libX11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-13 16:38 EDT by Joost Soeterbroek
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-13 17:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joost Soeterbroek 2006-05-13 16:38:41 EDT
Description of problem:
Missing Build Requires for libX11-devel and libX11

Version-Release number of selected component (if applicable):
pygtk2-2.8.6-1

How reproducible:
 mock -r fedora-development-i386-core.cfg --debug pygtk2-2.8.6-1.src.rpm

Steps to Reproduce:
 1. install mock
 2. mock -r fedora-development-i386-core.cfg --debug pygtk2-2.8.6-1.src.rpm
  
Actual results:
 DEBUG: Executing /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-i386-core/root install  'python2-devel >= 2.3'
'automake >= 1.6.3-5' 'libglade2-devel' 'pycairo-devel' 'python-numeric'
'gtk2-devel >= 2.4'
 Error: Missing Dependency: libX11-devel is needed by package gtk2-devel
 Error: Missing Dependency: libX11.so.6 is needed by package gtk2
 Error: Missing Dependency: libX11-devel is needed by package libXext-devel
 Error: Missing Dependency: libX11.so.6 is needed by package pango-devel
 Error: Missing Dependency: libX11-devel is needed by package pango-devel
 Error: Missing Dependency: libX11 is needed by package pango
 Error: Missing Dependency: libX11.so.6 is needed by package libXinerama
 Error: Missing Dependency: libX11.so.6 is needed by package libXft
 Error: Missing Dependency: libX11.so.6 is needed by package libXext
 Error: Missing Dependency: libX11.so.6 is needed by package libXrandr
 Error: Missing Dependency: libX11.so.6 is needed by package libXi
 Error: Missing Dependency: libXau.so.6 is needed by package libXext
 Error: Missing Dependency: libX11.so.6 is needed by package libXrender
 Error: Missing Dependency: libX11.so.6 is needed by package libXfixes
 Error: Missing Dependency: libX11.so.6 is needed by package libXcursor
 Error: Missing Dependency: libX11.so.6 is needed by package cairo
 Error: Missing Dependency: libX11.so.6 is needed by package pango
 Error: Missing Dependency: libX11-devel is needed by package mesa-libGL-devel
 Error: Missing Dependency: libX11.so.6 is needed by package mesa-libGL
 Error: Missing Dependency: libX11.so.6 is needed by package libXxf86vm
 Error peforming yum command: /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-development-i386-core/root install  'python2-devel >= 2.3'
'automake >= 1.6.3-5' 'libglade2-devel' 'pycairo-devel' 'python-numeric'
'gtk2-devel >= 2.4'
 
Expected results:
 successfull build in mock

Additional info:
Comment 1 Brian Pepple 2006-05-13 17:16:48 EDT
This is due to a problem with last nights Rawhide, and not a BR problem.

Note You need to log in before you can comment on or make changes to this bug.