Bug 191621 - Insides of OpenOffice windows are not visible to the a11y framework
Insides of OpenOffice windows are not visible to the a11y framework
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks: 169147
  Show dependency treegraph
 
Reported: 2006-05-13 19:25 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.3-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 12:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-05-13 19:25:43 EDT
Description of problem:
The various OpenOffice applications are only partially visible in the a11y framework

Version-Release number of selected component (if applicable):
at-spi-1.7.7-6
openoffice.org-impress-2.0.2-5.9.3
openoffice.org-core-2.0.2-5.9.3
openoffice.org-math-2.0.2-5.9.3
openoffice.org-calc-2.0.2-5.9.3
openoffice.org-graphicfilter-2.0.2-5.9.3
openoffice.org-base-2.0.2-5.9.3
openoffice.org-writer-2.0.2-5.9.3
openoffice.org-draw-2.0.2-5.9.3


How reproducible:
100%

Steps to Reproduce:
1.  Ensure a11y is enabled
  * Go to the desktop Preferences menu -> Preferences -> Accessibility ->
Assistive Technology Support
  * Ensure that the "Enable assistive technologies" checkbox is checked
  * Restart desktop session if necessary
2.  Install dogtail from Fedora Extras
3.  Start "oowriter"
4.  Run "sniff" (from dogtail), and try to find oowriter in the tree view
  
Actual results:
(i) The following is output:
GTK Accessibility Module initialized

** (swriter.bin:3434): WARNING **: unable to parse at-spi version number:
libspi.so.0

(ii) Within sniff the following hierarchy is visible:
  +-- main
      +--  various apps
      +--  swriter.bin (application)
           +-- Untitled1 - OpenOffice.org Writer (frame)
               +-- (untitled panel, with no descendents)

Expected results:
(i) We should see the "GTK Accessibility Module initialized", but the 2nd
message looks bogus.
(ii) There ought to be a complex hierarchy below swriter.bin, giving the full UI
of the program

Additional info:
Also seen with ooimpress and oocalc; looks like it affects the whole suite.
Comment 1 Caolan McNamara 2006-05-15 05:26:59 EDT
The a11y stuff is now the default upstream a11y solution, but they've added some
version checking stuff which isn't working. Have a simple workaround for this.

Note You need to log in before you can comment on or make changes to this bug.