Bug 191645 - NFS can't read public_content_t and can't write to public_content_rw_t
Summary: NFS can't read public_content_t and can't write to public_content_rw_t
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-14 13:53 UTC by Aurelien Bompard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 20:01:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aurelien Bompard 2006-05-14 13:53:10 UTC
Description of problem:
NFS should be able to read public_content_t files/dirs (and probably to write to
public_content_rw_t files/dirs too), since it is the point of those types.

But the access is not allowed in the selinux reference policy.
Here's a small patch to enable it :
=======================
--- policy/modules/services/rpc.te.orig 2006-05-14 15:43:55.000000000 +0200
+++ policy/modules/services/rpc.te      2006-05-14 15:45:43.000000000 +0200
@@ -109,6 +109,10 @@
 portmap_tcp_connect(nfsd_t)
 portmap_udp_chat(nfsd_t)

+# Access to public_content_t and public_content_rw_t
+miscfiles_read_public_files(nfsd_t)
+miscfiles_manage_public_files(nfsd_t)
+
 tunable_policy(`nfs_export_all_rw',`
        fs_read_noxattr_fs_files(nfsd_t)
        auth_manage_all_files_except_shadow(nfsd_t)
=======================

It is a diff against the rpc.te file in serefpolicy-2.2.34

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.2.36-2.fc5

How reproducible:
Always

Comment 1 Daniel Walsh 2006-06-16 01:54:04 UTC
Fixed in selinux-policy-2.2.47-3.fc5

Comment 2 Daniel Walsh 2007-03-28 20:01:20 UTC
Closing bugs



Note You need to log in before you can comment on or make changes to this bug.