Bug 191646 - (WaKKa) My soundcard doesn't word, this is the content of scsound.log
My soundcard doesn't word, this is the content of scsound.log
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 10:31 EDT by Nicola
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 09:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola 2006-05-14 10:31:48 EDT
------- System Config Soundcard --------
dom mag 14 16:26:55 CEST 2006

------- lspci --------
00:00.0 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc. VT8251 AHCI/SATA 4-Port Controller
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. Unknown device 3287
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCIE Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. Unknown device 3344
(rev 01)
02:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:00.1 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller

------- lsmod --------
Module                  Size  Used by
ppp_deflate             9793  0 
zlib_deflate           22233  1 ppp_deflate
ppp_async              15937  0 
ppp_generic            33109  2 ppp_deflate,ppp_async
slhc                   10561  1 ppp_generic
appletalk              41581  2 
ipx                    34661  2 
p8023                   6209  1 ipx
ppdev                  12741  0 
autofs4                22981  1 
i2c_dev                12741  0 
i2c_core               24897  1 i2c_dev
hidp                   24001  2 
rfcomm                 42709  0 
l2cap                  31681  10 hidp,rfcomm
bluetooth              52901  3 hidp,rfcomm,l2cap
sunrpc                140925  1 
ip_conntrack_netbios_ns     6977  0 
ipt_REJECT              9536  1 
xt_state                6209  2 
ip_conntrack           54040  2 ip_conntrack_netbios_ns,xt_state
nfnetlink              10457  1 ip_conntrack
xt_tcpudp               7233  4 
iptable_filter          7105  1 
ip_tables              16389  1 iptable_filter
x_tables               16965  4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
vfat                   16193  1 
fat                    51933  1 vfat
dm_mirror              24081  0 
dm_mod                 54745  1 dm_mirror
video                  18885  0 
button                 10577  0 
battery                13253  0 
ac                      8901  0 
ipv6                  246433  14 
stir4200               17988  0 
irda                  119289  1 stir4200
crc_ccitt               6209  2 ppp_async,irda
lp                     16265  0 
parport_pc             29413  1 
parport                38281  3 ppdev,lp,parport_pc
floppy                 61829  0 
nvram                  12617  0 
ehci_hcd               33229  0 
uhci_hcd               33233  0 
snd_hda_intel          21329  2 
snd_hda_codec         116033  1 snd_hda_intel
snd_seq_dummy           7749  0 
snd_seq_oss            33345  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                52401  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         12877  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            49105  0 
snd_mixer_oss          20417  1 snd_pcm_oss
snd_pcm                81093  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              26693  3 snd_seq,snd_pcm
snd                    55109  11
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              13345  1 snd
snd_page_alloc         14537  2 snd_hda_intel,snd_pcm
via_rhine              26949  0 
mii                     9281  1 via_rhine
ext3                  121417  2 
jbd                    56917  1 ext3

------- /etc/modprobe.conf --------
alias eth0 via-rhine

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0 
defaults.pcm.device 0 
defaults.ctl.card 0 

------- aplay -l --------
**** List of PLAYBACK Hardware Devices ****
card 0: VT82xx [HDA VIA VT82xx], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: VT82xx [HDA VIA VT82xx], device 1: AD198x Digital [AD198x Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

------- amixer --------
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 18 [58%] [on]
  Front Right: Playback 18 [58%] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 18 [58%] [on]
  Front Right: Playback 18 [58%] [on]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 18 [58%] [on]
  Front Right: Playback 18 [58%] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 0 [0%] [off]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 18 [58%] [on]
  Front Right: Playback 18 [58%] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Phone',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 15
  Mono:
  Front Left: Playback 15 [100%] [off]
  Front Right: Playback 15 [100%] [off]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Mono',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [off]
  Front Right: Playback 0 [0%] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 0 [0%] [off]
  Front Right: Capture 0 [0%] [off]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Stereo Downmix',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]

------- /proc/asound/version --------
Advanced Linux Sound Architecture Driver Version 1.0.11rc2 (Wed Jan 04 08:57:20
2006 UTC).

------- rpm -q alsa-lib --------
alsa-lib-1.0.11-3.rc2.2

------- rpm -q alsa-utils --------
alsa-utils-1.0.11-3.rc2

------- /proc/asound/modules --------
 0 snd_hda_intel

------- /proc/asound/pcm --------
00-01: AD198x Digital : AD198x Digital : playback 1
00-00: AD198x Analog : AD198x Analog : playback 1 : capture 1

------- system-config-soundcard --------

/usr/share/system-config-soundcard/soundcard.py:273: DeprecationWarning: use
gtk.ComboBox
  self.primarySubDeviceOptionMenu = gtk.OptionMenu()
/usr/share/system-config-soundcard/soundcard.py:308: GtkDeprecationWarning:
gtk.timeout_add is deprecated, use gobject.timeout_add instead
  self.timer = gtk.timeout_add (100, self.checkStatus, self)
/usr/share/system-config-soundcard/soundcard.py:548: GtkDeprecationWarning:
gtk.TRUE is deprecated, use True instead
  gtk.main()
aplay: main:547: audio open error: Dispositivo o risorsa occupata
aplay: main:547: audio open error: Dispositivo o risorsa occupata
aplay: main:547: audio open error: Dispositivo o risorsa occupata
Read config:
card 0
device 0
HW 0
----------- Kudzu -------------
Desc:           VIA Technologies, Inc. VIA High Definition Audio Controller
Driver:         snd-hda-intel
Device:         None

----------- **** -------------
Comment 1 Martin Stransky 2006-05-15 09:57:07 EDT
Your card is used by some other application,
could you check "$aplay /usr/share/sounds/phone.wav"? (on console)
Comment 2 Nicola 2006-05-16 12:33:34 EDT
I can't send it comand, console replies "bash: /usr/share/sounds/phone.wav:
Permission denied", and I'm root
Comment 3 Martin Stransky 2006-05-17 09:01:27 EDT
run this one "aplay /usr/share/sounds/phone.wav" as root....
Comment 4 Nicola 2006-05-18 09:07:46 EDT
I don't hear anything... just a whistle
Comment 5 Nicola 2006-05-19 14:59:20 EDT
How can i do for hear the audio in my pc? :(
Comment 6 Martin Stransky 2006-06-01 05:43:00 EDT
Any error messages? Like "audio open error"?
Comment 7 Nicola 2006-06-01 11:54:34 EDT
Something like that, I think...
Comment 8 Martin Stransky 2006-08-08 07:41:32 EDT
So please attach these error messages.
Comment 9 Nicola 2006-08-11 12:52:02 EDT
What error messages? Sorry but I'm a new Linux's user and I don't undestand well
everything.
I start my FC and, when I try to play a mp3, the program don't start, remaining
stoped. Exaple, I run Noautun, I select the mp3, I click to play but I don't
run. In the phones I hear just a strong whistle.
Comment 10 Martin Stransky 2006-08-14 08:15:27 EDT
Which program do you use for mp3 playback? Do you use any window manager like
KDE or Gnome? Do you use any sound daemon? (like esd or arts).

It looks like your card is used by an application and a playback program can't
access to it. (Usually only one application can use the sound card at the same
time).

Please check the Fedora FAQ:

http://fedoraproject.org/wiki/FAQ
Comment 11 Nicola 2006-09-26 13:55:23 EDT
So... I use, like I wrote in the last message, Noautun. But the error is the
same with every program.

I don't know what demon I use... I need demon?
Comment 12 Martin Stransky 2006-10-03 09:57:35 EDT
No, you don't need any sound daemon unless you want to use it. The situation is
that your card is used/occupied by some application and another application
can't use it....please check some forums for this issue.
Comment 13 Nicola 2006-10-03 14:37:42 EDT
The problem is the same with other linux system, too. I don't think the problem
will be that. According to me, is possible that the sound card isn't knew by the
system?

Note You need to log in before you can comment on or make changes to this bug.