Bug 191648 - I installed all the categorized packages through Add/Remove Software, then While i was installing extra packages available from the View as list on the left. one of the pages coused a bug (exception accured) the details are bellow.
I installed all the categorized packages through Add/Remove Software, then Wh...
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 11:38 EDT by Tomasz Bogosavac
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 13:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
its the error report from the fedora core asking to debug (1.17 KB, text/plain)
2006-05-14 11:38 EDT, Tomasz Bogosavac
no flags Details

  None (edit)
Description Tomasz Bogosavac 2006-05-14 11:38:14 EDT
Description of problem:

Component: Software Manager
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 363, in ?
    main()
  File "/usr/sbin/pirut", line 358, in main
    pm = PackageManager()
  File "/usr/sbin/pirut", line 56, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
    self.doPluginSetup(types=(yum.plugins.TYPE_CORE))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in
doPluginSetup
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__
    self.run('config')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb7997ecc>
parser: None




Version-Release number of selected component (if applicable):


How reproducible:
just install all the packages and then swich to list vire, show only available
packages, then start installing them all, or by the dozen untill you get to the
pacage that couses this error.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomasz Bogosavac 2006-05-14 11:38:14 EDT
Created attachment 129007 [details]
its the error report from the fedora core asking to debug
Comment 2 Jeremy Katz 2006-05-15 13:47:11 EDT

*** This bug has been marked as a duplicate of 191630 ***

Note You need to log in before you can comment on or make changes to this bug.