Bug 191658 - Xine runs out of colors after the first run when using Xv
Xine runs out of colors after the first run when using Xv
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-14 14:58 EDT by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 06:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (3.41 KB, text/plain)
2006-05-23 14:57 EDT, Paul Dickson
no flags Details
/var/log/Xorg.0.log (65.01 KB, text/plain)
2006-05-23 15:01 EDT, Paul Dickson
no flags Details

  None (edit)
Description Paul Dickson 2006-05-14 14:58:29 EDT
Description of problem:
I can use xine just fine the first time.  Once I exit xine and restart it, xine
appears to have run out of colors while displaying video.  If I use the option
"-V XShm" the output color is correct.

If I happen to be running the kernel 2064 (the last version that suspends and
hibernates on my machine) and I suspend the machine, on resuming xine displays
the video again correctly.


Version-Release number of selected component (if applicable):
libXv-1.0.1-1.2
xorg-x11-drv-i810-1.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. Run xine
2. Rerun xine
3.
  
Actual results:
After the first run, the video output appears just it did when using a 8-bit
color map and there's no longer room to allocate more colors.

Expected results:
The video to appear correctly.

Additional info:

From lspci:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 03)

Xine's FAQ (http://xinehq.de/index.php/faq#BUGGYXV) says this problem can happen
if the Xv extension is buggy.  This problems seems to have started in the last
couple of months.

Any suggestions for testing Xv other than xine (which is not part of Fedora)?
Comment 1 Mike A. Harris 2006-05-23 10:25:28 EDT
libXv is only the client side library, not the extension.

Reassigning to i810 driver component.  Please attach your X server log file
and config file as individual uncompressed attachments.
Comment 2 Paul Dickson 2006-05-23 14:57:49 EDT
Created attachment 129881 [details]
/etc/X11/xorg.conf
Comment 3 Paul Dickson 2006-05-23 15:01:57 EDT
Created attachment 129882 [details]
/var/log/Xorg.0.log
Comment 4 Paul Dickson 2006-07-25 04:20:21 EDT
Currently, I can't get xine or mplayer to fail.

I'm now running with: xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6

I did switch mplayer versions because I needed to remove directfb (the fc5
version, from extras) because of sysfs update.  I don't remember the depenency
reason why I switched xine.
Comment 5 Mike A. Harris 2006-07-26 06:46:07 EDT
(In reply to comment #4)
> Currently, I can't get xine or mplayer to fail.
> 
> I'm now running with: xorg-x11-drv-i810-1.6.0-11.20060713modeset.fc6
> 
> I did switch mplayer versions because I needed to remove directfb (the fc5
> version, from extras) because of sysfs update.  I don't remember the depenency
> reason why I switched xine.

Assuming the above comment means the problem is now resolved, and closing
as fixed in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.