Bug 19166 - crontab for systat doesn't work
Summary: crontab for systat doesn't work
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysstat (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-16 04:20 UTC by Ian Koenig
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 04:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Koenig 2000-10-16 04:20:37 UTC
I upgraded from RedHat 6.2 to 7.0.  In doing so it installed sysstat.

Since installing I have seen this official update on the net and updated
that to sysstat-3.2.4-4.i386.rpm.

This is the problem:

the /etc/crontab file doesn't run sa1 as the root and 0,6 are swapped.  As
such sa2 fails since the saXX files don't exist in /var/log/sa.

I have fixed and updated the crontab to what works properly (along with the
other stated related problem that has been posted here under sysstat bugs)

Fix:
----------------
# sysstat
0 * * * 0-6 root /usr/lib/sa/sa1 600 6 &
5 19 * * * root /usr/lib/sa/sa2 -A &
----------------

Comment 1 Tim Waugh 2000-10-16 11:41:40 UTC
There is a new update.

Comment 2 Ian Koenig 2000-10-16 16:35:41 UTC
I installed the update sysstat-3.2.4-5.rpm.  However the updated package fixed
one problem.

The problem that still remains is the fact that in the crontab sa1 is setup to
run on Sunday and Sat.. Not Sunday Through Saturday.

The fix is
0 * * * 0-6 root /usr/lib/sa/sa1 600 6 &

instead of 
0 * * * 0,6 root /usr/lib/sa/sa1 600 6 &


Note You need to log in before you can comment on or make changes to this bug.