Bug 191662 - sonypi module not autoloading
sonypi module not autoloading
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2006-05-14 16:10 EDT by Casual J. Programmer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-29 05:55:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Casual J. Programmer 2006-05-14 16:10:01 EDT
Hello pknirsch, harald,

not sure wether Miles really solved the issue. I installed FC5 on a Sony Vaio
PCG-SRX51P with Touch Pad and Jog Dial. Sonypi comes with the FC5 installation,
but it does not get automatically loaded at boot time, so I guess the hardware
is just not being detected correctly.

This is related to: Linux WORKSTATION1FC5 2.6.16-1.2111_FC5 #1 Thu May 4
21:16:58 EDT 2006 i686 i686 i386 GNU/Linux

Installing spicctrl later, put the alias in the modprobe.conf file, but doesn't
cause sonypi to be loaded at boottime. 

When sonypi is loaded manually, a device /dev/sonypi is created and the jogdial
can be used for scrolling. Also spicctrl works flawless.

For the time being I followed advice from
www.csanyi.net/wiki/space/x505+linux+install ( alas the link is broken, the
content is visible in google ) and added /sbin/modprobe sonypi to /etc/rc.local
as a workaround to load sonypi on booting.

The problem still needs to be fixed in the distribution.

+++ This bug was initially created as a clone of Bug #189579 +++

I've just upgraded my Sony PGC-Z1XSP from FC3 to FC5, and I'm having a 
problem getting the sonypi module to load on boot (a manual modprobe 
sonypi works perfectly). This is almost certainly a udev problem, and I 
had it working perfectly with udev under FC3, but things have changed a 
little since then and I'm out of ideas so any suggestions would be most 

I have the following in my modprobe.conf,

  alias char-major-10-250 sonypi
  options sonypi minor=250

and I've added the following files,


  c $CONSOLE 10 250 1 1 sonypi



  KERNEL="sonypi", NAME="%k", MODE="0666"

but with no discernable effect ... can anyone give me any pointers to 
what I'm missing?

-- Additional comment from harald@redhat.com on 2006-04-21 07:42 EST --
I guess the sonypi has no sysfs entry ("dev") in /sys .
Just create a file in /etc/udev/makedev.d/

-- Additional comment from miles@milessabin.com on 2006-04-21 17:00 EST --
Thanks for that. I tried following your advice, and on boot I now get the
following error message,

  Starting udev: error parsing "/etc/makedev.d/51-sonypi.nodes" : unknown group
in "sonypi"

Immediately after boot,

  find /sys -name "*sony*" -print

finds nothing, but after a manual modprobe sonypi it gives me,


Any hints on how to proceed from here would be much appreciated.

-- Additional comment from miles@milessabin.com on 2006-04-21 17:09 EST --
Ignore that last comment: I created the file in /etc/makedev.d rather than
/etc/udev/makedev.d. With it installed in the right place the device node is
created as expected.
Comment 1 Phil Knirsch 2007-05-16 06:02:29 EDT
Reassigning to udev (see later comments).

Read ya, Phil
Comment 2 Harald Hoyer 2007-05-29 05:55:10 EDT
in FC6 and later versions, sonypi is loaded by

Note You need to log in before you can comment on or make changes to this bug.