Bug 19168 - Kernel compiling impossible on several totaly different machines
Summary: Kernel compiling impossible on several totaly different machines
Status: CLOSED DUPLICATE of bug 18359
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i586 Linux
high
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-16 09:42 UTC by Jasmin Buchert
Modified: 2007-03-27 03:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-16 09:54:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jasmin Buchert 2000-10-16 09:42:14 UTC
Kernel compiling is impossible on my i586 and i686 Computer (both computers
are working perfect on several other linux systems). I tryed the included
Redhat Kernel 2.2.16, the 2.2.16 kernel of www.kernel.org and the 2.2.17
kernel of www.kernel.org.
All this kernels wont work!

The error messages while compiling Redhat Kernel 2.2.16-22:
(i compiled with make clean, make dep and make bzImage!!!)

/usr/src/linux/include/linux/modules/i386_ksyms.ver:138: warning: this is
the location of the previous definition In file included from
/usr/src/linux/include/linux/interrupt.h:52,                  from
ksyms.c:21: /usr/src/linux/include/asm/softirq.h:75: warning:
`synchronize_bh' redefined
/usr/src/linux/include/linux/modules/i386_ksyms.ver:142: warning: this is
the location of the previous definition
/usr/src/linux/include/linux/kernel_stat.h: In function `kstat_irqs': In
file included from ksyms.c:17:
/usr/src/linux/include/linux/kernel_stat.h:47: `smp_num_cpus' undeclared
(first use in this function) /usr/src/linux/include/linux/kernel_stat.h:47:
(Each undeclared identifier is reported only once
/usr/src/linux/include/linux/kernel_stat.h:47: for each function it appears
in.) make[2]: *** [ksyms.o] Fehler 1 make[2]: Verlassen des Verzeichnisses
Verzeichnis ;/usr/src/linux-2.2.16/kernel+ make[1]: *** [first_rule] Fehler
2 make[1]: Verlassen des Verzeichnisses Verzeichnis
;/usr/src/linux-2.2.16/kernel+ make: *** [_dir_kernel] Fehler 2

Comment 1 Arjan van de Ven 2000-10-16 09:54:03 UTC
This is a duplicate of bug 18359. You need to do a "make mrproper" before
compiling a UP kernel from these sources. (remember to save and later restore
your .config file, as make mrproper deletes it).

Comment 2 Alan Cox 2000-10-16 23:49:32 UTC

*** This bug has been marked as a duplicate of 18359 ***


Note You need to log in before you can comment on or make changes to this bug.