Bug 191684 - cdrdao can't be used as normal user
cdrdao can't be used as normal user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cdrdao (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 02:47 EDT by Rouquier Philippe
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: cdrdao-1.2.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 07:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace -f cdrdao blank --device /dev/cdrom 2> cdrdao.txt" (8.36 KB, text/plain)
2006-08-26 15:30 EDT, Andre Robatino
no flags Details

  None (edit)
Description Rouquier Philippe 2006-05-15 02:47:40 EDT
Description of problem:
Whenever a normal user tries to use cdrdao it fails saying that it can send SCSI
commands but works flawlessly when used as root.

Version-Release number of selected component (if applicable):
1.2.1-1

How reproducible:
always

Steps to Reproduce:
Use it as a normal user whether to write or read a disc.
Type cdrdao read-toc --device /dev/hda /tmp/test for example

Actual results:
cdrdao says (and that's the same whatever you do):
"cdrdao: Operation not permitted. Cannot send SCSI cmd via ioctl"
Comment 1 Harald Hoyer 2006-05-15 05:02:28 EDT
which kind of drive fo you have?
Comment 2 Rouquier Philippe 2006-05-15 12:23:39 EDT
I have an internal DVD writer (laptop type) drive. Its name as reported by Hal is 
HL-DT-ST DVD-RW GCA4080N.
The same thing happens with my external USB/Firewire plextor DVD-RW.
Comment 3 Jeff Peterson 2006-05-25 20:46:54 EDT
cdrdao-1.1.9-9 works fine as a normal user. I have an internal PleXwriter
12/10/32 SCSI drive. I just installed the older revision from the Fedora Core 4 CD.
Comment 4 Andre Robatino 2006-08-26 15:30:49 EDT
Created attachment 134983 [details]
output of "strace -f cdrdao blank --device /dev/cdrom 2> cdrdao.txt"
Comment 5 Andre Robatino 2006-08-26 15:32:52 EDT
  I can verify the problem with a CyberDrive CW038D CD-RW drive.  The only I've
tried that works as an ordinary user is "cdrdao scanbus".  Above is attached
strace output for a failed blank operation as an ordinary user.
Comment 6 Andre Robatino 2006-08-26 17:48:51 EDT
  Same failure using a Sony CRX310EE CD-RW/DVD-ROM drive in the same machine. 
Doesn't appear to be drive-dependent for me.  Exact procedure I followed:

1) Put a non-blank CD in the drive.  Close door.
2) After it automounts, unmount with "umount /dev/cdrom" as root.
3) Try "cdrdao blank --device /dev/cdrom" as ordinary user.  Fails as above.
4) Try "cdrdao blank --device /dev/cdrom" as root.  Succeeds.
Comment 7 Andre Robatino 2006-08-31 16:09:57 EDT
  I downloaded cdrdao-1.2.1.tar.bz2 from cdrdao.sourceforge.net, did
"./configure" and "make", and the resulting cdrdao executable works fine as an
ordinary user.  So the problem is something FC5-specific.

------------------------------------------------------------------------------------------
Output from SourceForge cdrdao doing blanking as an ordinary user:
------------------------------------------------------------------------------------------

[andre@localhost dao]$ eject -t ; ./cdrdao blank --device /dev/cdrom
Cdrdao version 1.2.1 - (C) Andreas Mueller <andreas@daneb.de>
  SCSI interface library - (C) Joerg Schilling
  Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

Using libscg version 'schily-0.8'

/dev/cdrom: SONY CDRWDVD CRX310EE       Rev: SDK3
WARNING: Cannot read driver table from file "/usr/local/share/cdrdao/drivers" -
using built-in table.
Using driver: Generic SCSI-3/MMC - Version 2.0 (options 0x0000)

Blanking disk...
Blanking time: 24 seconds
[andre@localhost dao]$

-------------------------------------------------------------------------------
Output from FC5 cdrdao doing blanking as an ordinary user:
-------------------------------------------------------------------------------

[andre@localhost ~]$ eject -t ; cdrdao blank --device /dev/cdrom
Cdrdao version 1.2.1 - (C) Andreas Mueller <andreas@daneb.de>
  SCSI interface library - (C) Joerg Schilling
  Paranoia DAE library - (C) Monty

Check http://cdrdao.sourceforge.net/drives.html#dt for current driver tables.

Using libscg version 'schily-0.8'

/dev/cdrom: SONY CDRWDVD CRX310EE       Rev: SDK3
Using driver: Generic SCSI-3/MMC - Version 2.0 (options 0x0000)

cdrdao: Operation not permitted. Cannot send SCSI cmd via ioctl
[andre@localhost ~]$
Comment 8 Charles Curley 2006-08-31 19:29:28 EDT
I can confirm the same problem on my Lenovo R51
(http://www.charlescurley.com/Lenovo.R51.html). cdrecord -scanbus reports the
drive as "1,0,0   100) 'HL-DT-ST' 'RW/DVD GCC-4241N' '1.04' Removable CD-ROM". I
can use K3B with the drive just fine.
Comment 9 Jeff Peterson 2006-08-31 22:52:37 EDT
I just downloaded the Cdrdao version 1.2.1 from cdrdao.sourceforge.net today and
compiled it. I was able to successfully burn a CD as a normal user using the
newly compiled version. So, what is different than the Fedora Core 5 supplied
version?
Comment 10 Andre Robatino 2006-09-01 00:24:01 EDT
  Well, the tarball from SourceForge is from 11/2005.  So FC5 is working off
exactly the same upstream code.  Figuring out what customizations are causing
the problem should be almost trivial.  In fact, I don't know why there need to
be any customizations at all - they could just create an RPM by applying
rpmbuild to the tarball.
Comment 11 Andre Robatino 2006-09-01 15:29:38 EDT
  Can someone running FC6t2 check whether this bug currently exists in it?  I
asked on fedora-test-list but haven't gotten a response.  If it's gone then it
was probably just a one-time packaging or compiling mistake.  If not, then it
should be reported in Bugzilla against FC6t2 to try to keep it out of FC6.

http://www.redhat.com/archives/fedora-test-list/2006-August/msg00603.html 
Comment 12 Andre Robatino 2006-09-06 16:45:35 EDT
  I got replies to a second post to fedora-test-list indicating that cdrdao does
work as a normal user in FC6t2.  So this problem should go away in FC6.

http://www.redhat.com/archives/fedora-test-list/2006-September/msg00120.html

http://www.redhat.com/archives/fedora-test-list/2006-September/msg00122.html

(I'm guessing the failure to blank in the second response was due to the disc
being mounted when cdrdao tried to write.)
Comment 13 Andre Robatino 2006-10-25 05:54:39 EDT
  Just confirmed that this is in fact fixed in FC6.
Comment 14 redtux 2007-05-21 06:23:40 EDT
This bug has resurfaced in FC7 test 4. In fact is worse - cdrdao scanbus 
returns no info as normal user and works as root.

Comment 15 Harald Hoyer 2007-06-21 06:38:05 EDT
Still a problem?

Are you sure the drive is not mounted/locked by the automount feature?
gnome-volume-properties to change the policy...
Comment 16 Andre Robatino 2007-06-21 06:44:01 EDT
  The disc blanking test I tried above works for me as an ordinary user in F7.

Note You need to log in before you can comment on or make changes to this bug.