Bug 191708 - gfs_fsck doesn't work on large filesystems
gfs_fsck doesn't work on large filesystems
Status: CLOSED DUPLICATE of bug 186125
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 07:53 EDT by Stephen Willey
Modified: 2010-01-11 22:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-15 09:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Willey 2006-05-15 07:53:20 EDT
Description of problem:

GFS fsck seems to bomb out on large filesystems.

Version-Release number of selected component (if applicable): GFS-6.1.5

How reproducible:

Create a gfs filesystem and fsck it.
The fsck has worked on 137Gb, 2Tb and 4.4Tb filesystems.
It fails on 6.5Tb and above.
If you wish, I can narrow down the filesystem size at which it fails.
  
Actual results:

gfs_fsck /dev/sda -vvvvvvvvv gives

Initializing fsck
Initializing lists...
(bio.c:140)     Writing to 65536 - 16 4096
Initializing special inodes...
(file.c:45)     readi:  Offset (640) is >= the file size (640).
(super.c:208)   8 journals found.
ATTENTION -- not doing gfs_get_meta_buffer...

Additional info:

strace gfs_fsck /dev/sda -vvvvvvvvvvvvv

execve("/sbin/gfs_fsck", ["gfs_fsck", "/dev/sda", "-vvvvvvvvvvvvvvv"], [/* 26
vars */]) = 0
uname({sys="Linux", node="gfstest1", ...}) = 0
brk(0)                                  = 0x526000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2a95556000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=185969, ...}) = 0
mmap(NULL, 185969, PROT_READ, MAP_PRIVATE, 3, 0) = 0x2a95557000
close(3)                                = 0
open("/lib64/tls/libc.so.6", O_RDONLY)  = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\305\221"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1493186, ...}) = 0
mmap(0x3cd2900000, 2310056, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3,
0) = 0x3cd2900000
mprotect(0x3cd2a2b000, 1085352, PROT_NONE) = 0
mmap(0x3cd2b2a000, 24576, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x12a000) = 0x3cd2b2a000
mmap(0x3cd2b30000, 16296, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x3cd2b30000
close(3)                                = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2a95585000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x2a95586000
mprotect(0x3cd2b2a000, 12288, PROT_READ) = 0
arch_prctl(ARCH_SET_FS, 0x2a95585b00)   = 0
munmap(0x2a95557000, 185969)            = 0
write(1, "Initializing fsck\n", 18Initializing fsck
)     = 18
open("/dev/sda", O_RDWR)                = 3
sync()                                  = 0
write(1, "Initializing lists...\n", 22Initializing lists...
) = 22
brk(0)                                  = 0x526000
brk(0x547000)                           = 0x547000
lseek(3, 65536, SEEK_SET)               = 65536
read(3, "\1\26\31p\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0d\0\0\0\0\0\0\5"..., 512) = 512
lseek(3, 65536, SEEK_SET)               = 65536
read(3, "\1\26\31p\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0d\0\0\0\0\0\0\5"..., 4096) = 4096
lseek(3, 65536, SEEK_SET)               = 65536
write(1, "(bio.c:140)\t", 12(bio.c:140) )           = 12
write(1, "Writing to 65536 - 16 4096\n", 27Writing to 65536 - 16 4096
) = 27
write(3, "\1\26\31p\0\0\0\1\0\0\0\0\0\0\0\0\0\0\0d\0\0\0\0\0\0\5"..., 4096) = 4096
fsync(3)                                = 0
write(1, "Initializing special inodes...\n", 31Initializing special inodes...
) = 31
lseek(3, 94208, SEEK_SET)               = 94208
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 106496, SEEK_SET)              = 106496
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\2\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
lseek(3, 90112, SEEK_SET)               = 90112
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
write(1, "(file.c:45)\t", 12(file.c:45) )           = 12
write(1, "readi:  Offset (640) is >= the f"..., 48readi:  Offset (640) is >= the
file size (640).
) = 48
write(1, "(super.c:208)\t", 14(super.c:208)     )         = 14
write(1, "8 journals found.\n", 188 journals found.
)     = 18
lseek(3, 94208, SEEK_SET)               = 94208
read(3, "\1\26\31p\0\0\0\4\0\0\0\0\0\0\0\0\0\0\1\220\0\0\0\0\0\0"..., 4096) = 4096
write(2, "ATTENTION -- not doing gfs_get_m"..., 46ATTENTION -- not doing
gfs_get_meta_buffer...
) = 46
exit_group(1)                           = ?
Process 6247 detached
Comment 1 Robert Peterson 2006-05-15 09:43:50 EDT
This is the same bug as 186125.  A hot fix is available for it.

*** This bug has been marked as a duplicate of 186125 ***

Note You need to log in before you can comment on or make changes to this bug.