Bug 191710 - Deprecated pam_stack module called from service "imap"
Deprecated pam_stack module called from service "imap"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 08:38 EDT by Bob Chiodini
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: cyrus-imapd-2.3.1-2.7.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 13:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix the warning issue (2.30 KB, patch)
2006-11-17 09:52 EST, Alain RICHARD
no flags Details | Diff

  None (edit)
Description Bob Chiodini 2006-05-15 08:38:35 EDT
Description of problem:

Deprecated pam_stack module called from service "imap"


Version-Release number of selected component (if applicable):

pam-0.99.3.0-2


How reproducible:

always

Steps to Reproduce:

Open an IMAP session
  
Actual results:

Logged message:  Deprecated pam_stack module called from service "imap"

Expected results:

No messages

Additional info:

Following changes to  /etc/pam.d/imap stop the messages:

#%PAM-1.0
#auth       required    pam_stack.so service=system-auth
#account    required    pam_stack.so service=system-auth
auth       include      system-auth
account    include      system-auth
Comment 1 Paul Howarth 2006-05-15 08:45:01 EDT
Similar changes would also be needed to the other pam config files in the package
Comment 2 Tomas Mraz 2006-05-15 09:21:35 EDT
Please reassign the bug to the package owning the /etc/pam.d/imap files.
Comment 3 Bob Chiodini 2006-05-16 11:52:52 EDT
Tomas,

What info do you need?

Bob...
Comment 4 Tomas Mraz 2006-05-16 11:56:12 EDT
See my comment above. The /etc/pam.d/imap is not part of pam package.
Comment 5 Bob Chiodini 2006-05-16 12:16:28 EDT
Tomas,

Understood.  I was confused about the NEEDINFO_REPORTER status from comment 2.

Bob...
Comment 6 Tomas Mraz 2006-05-18 06:30:00 EDT
The requested info is: which package /etc/pam.d/imap belongs to? And could you
please reassign the bug report to the appropriate package?
Comment 7 Andrew Baumann 2006-07-03 20:33:09 EDT
Ping? This is a trivial bug to fix for the cyrus-imapd maintainer; I've just 
made the same discovery and the same fix in my FC5 install.
Comment 8 Sam Azer 2006-08-11 12:04:18 EDT
The correction specified above works for me. As sort-of mentioned above, the
same correction should be applied to the pop service in cyrus-imapd; ie: as I am
using both the imap and pop services, I found it necessary to 'cp
/etc/pam.d/imapd /etc/pam.d/pop'

HTH
Comment 9 Alain RICHARD 2006-11-17 09:52:54 EST
Created attachment 141478 [details]
fix the warning issue
Comment 10 John Dennis 2006-12-05 13:21:02 EST
fixed in cyrus-imapd-2.3.1-2.7.fc5

Note You need to log in before you can comment on or make changes to this bug.