Bug 191765 - Specifying mem=XXX on NUMA ia64 boxes can lead to system panic
Specifying mem=XXX on NUMA ia64 boxes can lead to system panic
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
Depends On:
Blocks: 170416
  Show dependency treegraph
 
Reported: 2006-05-15 13:32 EDT by Prarit Bhargava
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 16:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2006-05-15 13:32:24 EDT
Description of problem:

Specifying mem=XXX on NUMA ia64 boxes can lead to system panic.

Version-Release number of selected component (if applicable):
kernel-2.6.9-34.EL

How reproducible: 100%


Steps to Reproduce:
1. Boot large memory system (128GB) with mem=32GB on the boot cmdline

  
Actual results:

Uncompressing Linux... done
Loading initrd initrd-2.6.9-34.EL.img...done
Linux version 2.6.9-34.EL (bhcompile@altix2.build.redhat.com) (gcc version 3.4.5
20051201 (Red Hat 3.4.5-2)) #1 SMP Fri Feb 24 16:49:08 EST 2006
EFI v1.10 by INTEL: SALsystab=0x3002814b60 ACPI 2.0=0x300281b8e0
booting generic kernel on platform sn2
Number of logical nodes in system = 32
Number of memory chunks in system = 32
efi.trim_top: ignoring 8KB of memory at 0x2b400000000 due to granule hole at
0x2b452000000
Kernel panic - not syncing: pernode space for node 31 could not be allocated!

Expected results:

Boot should succeed.

Additional info: Upstream patch fixes this:

http://marc.theaimsgroup.com/?l=linux-ia64&m=109718964113183&w=2
Comment 1 Jay Turner 2006-05-16 15:10:18 EDT
While with a well-functioning system there's no reason for a customer to pass
"mem=" to a machine, we do utilize that flag for working around and debugging
other issues so really should ensure that it works on all architectures.
Comment 4 Prarit Bhargava 2006-05-17 17:36:37 EDT
This has been broken all along in RHEL4 and is not a regression.  Since no one
has complained about it yet, I suggest pushing this into RHEL4 U5.

P.

Note You need to log in before you can comment on or make changes to this bug.