Bug 191854 - krb5-config is not in the path, but is referenced as if it was
krb5-config is not in the path, but is referenced as if it was
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-15 23:31 EDT by Zenon Panoussis
Modified: 2008-03-18 12:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 12:09:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2006-05-15 23:31:27 EDT
Description of problem:

/usr/src/redhat/BUILD/cyrus-sasl-2.1.21
++ krb5-config --prefix
/var/tmp/rpm-tmp.82348: line 43: krb5-config: command not found
+ krb5_prefix=
error: Bad exit status from /var/tmp/rpm-tmp.82348 (%build)

Either should /usr/kerberos/bin be in the path, or the 
cyrus-sasl .spec should add it.

Version-Release number of selected component (if applicable):
krb5-devel-1.4.3-4.1
cyrus-sasl-2.1.21-10.src.rpm
Comment 1 Nalin Dahyabhai 2008-03-18 12:09:13 EDT
The scriptlet which krb5-devel drops into /etc/profile.d should have been
sourced either by the invoking shell or one of its ancestors, which means that
this is not the normal behavior of things.

So far as I can tell, you should only ever see this error if the krb5-devel
package had been installed after you had logged in, and I don't see a way to
solve that case except for hard-coding the location of the script everywhere it
might be used, which generally isn't favored (hence the use of profile.d).

I'm going to mark this as won't-fix because I don't currently plan to make
changes to the package to try to address the case where the package was
installed after the user logged in.  If you're seeing this behavior crop up in a
different scenario, though, please reopen this bug.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.