Bug 191919 - dm mirroring: Unable to create single machine mirror with core log
dm mirroring: Unable to create single machine mirror with core log
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-05-16 10:11 EDT by Jonathan Earl Brassow
Modified: 2010-01-11 21:16 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2006-0434
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:24:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix problem (907 bytes, patch)
2006-05-16 10:11 EDT, Jonathan Earl Brassow
no flags Details | Diff

  None (edit)
Description Jonathan Earl Brassow 2006-05-16 10:11:08 EDT
device-mapper/lib/libdm-deptree.c:_emit_segment_line() improperly handles the
counting of parameters - causing an inability to create single machine mirrors
with core logs.

This is essential to the correct operation of LVM2 mirroring, because LVM2 relys
on being able to create mirrors with core logs in order to cope with the failure
of the disk log device.
Comment 1 Jonathan Earl Brassow 2006-05-16 10:11:08 EDT
Created attachment 129193 [details]
Patch to fix problem
Comment 5 Red Hat Bugzilla 2006-08-10 17:24:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0434.html

Note You need to log in before you can comment on or make changes to this bug.