Bug 191999 - 4.1.1-37 breaks authentication completely
4.1.1-37 breaks authentication completely
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
: 192185 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 14:53 EDT by David Rees
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-22 07:36:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Rees 2006-05-16 14:53:18 EDT
Description of problem:
Any attempt to connection to vnc-server with the latest version on FC5 results
in a disconnection.

Version-Release number of selected component (if applicable):
4.1.1-37.fc5

How reproducible:
Every single time.

Steps to Reproduce:
1. Start VNC# vncserver :1
2. Try to connect# vncviewer localhost:1
3. Viewer Disconnected
  
Actual results:
Viewer is disconnected, no login prompt shown.

Expected results:
Viewer should show login prompt.

Additional info:
Server log shows this:
Tue May 16 11:54:44 2006
 Connections: accepted: 127.0.0.1::35980
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)
 SConnection: unexpected security type
 Connections: closed: 127.0.0.1::35980 (unexpected security type)

Viewer shows this:
Tue May 16 11:54:44 2006
 CConn:       connected to host localhost port 5901
 CConnection: Server supports RFB protocol version 3.8
 CConnection: Using RFB protocol version 3.8
 main:        End of stream

All versions of viewers I have tried result in the same thing.
Comment 1 Mathias Mistrik 2006-05-17 11:52:38 EDT
exactly the same on FC4 with vnc-server-4.1.1-10.1.fc4 and vnc-4.1.1-10.1.fc4
Comment 2 stephen 2006-05-17 20:32:28 EDT
I have the same client output on my client machine after I updated vnc server on
the server (FC4).

Comment 3 Jitka Kozana 2006-05-18 06:45:22 EDT
*** Bug 192185 has been marked as a duplicate of this bug. ***
Comment 4 mgm 2006-05-18 14:47:17 EDT
Same problem even when SecurityType set to None:

Thu May 18 14:31:54 2006
 Connections: accepted: 127.0.0.1::58694
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type None(1)
 SConnection: unexpected security type
 Connections: closed: 127.0.0.1::58694 (unexpected security type)
Comment 5 Jon Haswell 2006-05-18 15:16:17 EDT
However specifying -Protocol3.3 (to Xvnc) is a way of bypassing the problem - 
not surprisingly perhaps.

Note You need to log in before you can comment on or make changes to this bug.