Bug 19200 - Fonts are unreadable in Netscape
Fonts are unreadable in Netscape
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-16 16:08 EDT by Dave Weis
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-28 06:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a small clip of netscape (9.00 KB, image/jpeg)
2000-10-16 16:13 EDT, Dave Weis
no flags Details

  None (edit)
Description Dave Weis 2000-10-16 16:08:53 EDT
I installed a fresh copy of RH 7.0 and am having some font problems. If I
look at the page
http://www.cnn.com/2000/TECH/computing/10/15/internetfiltering.ap/index.html
the widths look incorrect, and possibly the heights, but not by as much.
Here are the XFree86 RPMS I have installed
XFree86-xfs-4.0.1-1
XFree86-tools-4.0.1-1
XFree86-V4L-4.0.1-1
XFree86-4.0.1-1
XFree86-75dpi-fonts-4.0.1-1
XFree86-twm-4.0.1-1
XFree86-doc-4.0.1-1
XFree86-100dpi-fonts-4.0.1-1
XFree86-libs-4.0.1-1
XFree86-devel-4.0.1-1
XFree86-xdm-4.0.1-1
I am using xinerama on two 19" Optiquest V95 monitors. It functions
correctly.
Comment 1 Dave Weis 2000-10-16 16:13:43 EDT
Created attachment 4227 [details]
This is a small clip of netscape
Comment 2 Alan Cox 2000-10-16 19:38:09 EDT
Does rpm --erase abiword fix it ?
Comment 3 Dave Weis 2000-10-17 09:04:54 EDT
I don't have abiword installed.

Comment 4 Geoff Reedy 2000-10-19 17:08:12 EDT
I've had this problem before, and remeber reading something about why it
happens.  I seem to recall that netscape is rather stupid about the way it
chooses what size font to use.  I think it was something like if a page
specified a 10point font then netscape would choose a 10pixel high font.  Which
if you are running a rather high resolution is not very easy to read, especially
if netscape for some reason picks a non-scalable font.  Looking at a 10 pixel
high, scaled down bitmap font is not fun by any stretch of the imagination.  As
a workaround under font preferences set it to always use your fonts and override
those that the page specifies.  It can and will cause some pages to render
incorrectly, but at least you can read them.  FWIW, mozilla and consequently
Netscape 6 whenever it is ready for a real release is much better about this.
Comment 5 giulioo 2000-12-10 12:10:54 EST
I have the same problem, no abiword, 1024x768.

I read and tried what is said here:
http://people.redhat.com/scoile/fonts/fixing.html
http://home.c2i.net/dark/linux.html#ttf
http://www.linuxdoc.org/HOWTO/mini/FDU/apps.html#AEN480
and installed windows ttf.

www.cnn.com (which I used as a test) is far better now, but the css .blue + 
bold used for important link is still very ugly.
<span class="blue" style="font-weight: bold;">
.blue {font-size:12px; 
font-family:arial, helvetica, verdana; 
color:#000099}

Maybe in future releases RedHat could do by default something similar to what 
the links suggest, even because they disagree on some issues and I'm not able 
to say which is the best, while RedHat should now it better :-)

Comment 6 Dave Weis 2001-04-23 16:00:47 EDT
After six months, this has become moot. I've tried it with 7.1 and it seems
better, but still not perfect.
Comment 7 Mike A. Harris 2001-05-04 04:57:33 EDT
Most likely the dpi XFree86 is seeing your monitor as and the actual DPI
of your monitor are not the same.  Please attach your XFree86 server logs
and your config file via the file attachment link below.

Try starting X with the parameter "-dpi <yourdpi>" where yourdpi is the dpi
of the video mode/monitor combo.  Something like:

startx -- -dpi 100

If that doesn't change anything, try uninstalling the 100dpi fonts and
installing the 75 dpi fonts instead, or vice versa.  Restart both xfs
and XFree86 in between any changes.
Comment 8 Mike A. Harris 2001-07-28 06:41:24 EDT
This is almost definitely due to monitor DPI calculations giving
different vert/horiz DPI.  You need to specify your width/height
in your config to fix this.
Comment 9 Mike A. Harris 2001-09-13 02:41:17 EDT
I consider this a special case configuration issue.  All distorted
font issues seem to be fixed by using advice contained above for
other users experiencing these sort of problems, in particular all of the
recommended solutions are:

1) Removing from font path 75dpi/100dpi scaled fonts, leaving only the
   unscaled versions.

2) Calculating the monitor's DPI and starting X with -dpi or by using
   the DisplaySize in XF86Config-4 to specify monitor dimensions.

3) Only installing either the 75 dpi font or the 100dpi font depending
   on what specific DPI more closely matches that of the given monitor
   size, and resolution settings.


Note You need to log in before you can comment on or make changes to this bug.