Bug 192001 - Dice and card games are forbidden in Islamic countries
Dice and card games are forbidden in Islamic countries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 14:57 EDT by Hooman Mesgary
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 05:15:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to apply on gnome-games in FC4 to make dice and card games removable easily. (5.07 KB, patch)
2006-05-16 14:57 EDT, Hooman Mesgary
no flags Details | Diff
screenshot of gnome-games in application menu. (48.71 KB, image/png)
2006-05-21 14:19 EDT, Hooman Mesgary
no flags Details

  None (edit)
Description Hooman Mesgary 2006-05-16 14:57:11 EDT
Description of problem:
As the dice and card games are forbidden in Islamic countries (because they are
considered gambling instruments), they should be removable easily (or get
removed) from gnome games.

A good idea is to define a variable in spec file for dice and another for card
games (like what happened for gnome-stones). And assign 0 or 1 to it to make it
unavailable or available in built RPMs.

Version-Release number of selected component (if applicable):
gnome-games-2.10.0-5

How reproducible:
Always

Steps to Reproduce:
1. install gnome-games
2. check the games installed, there is Tali and some card games
  
Actual results:
There is Tali and some card games.

Expected results:
a gnome-games without Tali and any card games.

Additional info:
I have a patch to apply on spec file for gnome-games in FC4. I can port it to
FC5 if desired.

FarsiWeb's internal reference:
farsiweb #151, reported by Roozbeh Pournader,
fix by Hooman Mesgary
Comment 1 Hooman Mesgary 2006-05-16 14:57:11 EDT
Created attachment 129259 [details]
A patch to apply on gnome-games in FC4 to make dice and card games removable easily.
Comment 2 Ray Strode [halfline] 2006-05-16 15:34:12 EDT
Hi,

I applied your fix to rawhide.  Can you try source packages in tomorrow's
compose and tell me if they work the way you want?
Comment 3 Hooman Mesgary 2006-05-21 14:17:59 EDT
I build it and test it.
all the things was ok, except the "Robots" hasn't icon in Application menu.
check the (will attach) screenshot.
Comment 4 Hooman Mesgary 2006-05-21 14:19:45 EDT
Created attachment 129782 [details]
screenshot of gnome-games in application menu.

There is no icon for Robots.
It is taken from "gnome-games-2.15.2-1"
Comment 5 Matthias Clasen 2006-08-03 10:16:15 EDT
Robots has an icon nowadays.
Comment 6 Roozbeh Pournader 2006-08-12 05:13:17 EDT
(In reply to comment #5)
> Robots has an icon nowadays.

I guess you closed the wrong bug. Reopening.
Comment 7 Roozbeh Pournader 2006-08-12 05:15:37 EDT
Oops. My mistake.

Note You need to log in before you can comment on or make changes to this bug.