This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 192016 - [FC5] LTC23920-SCIM XIM server returns unexpected data
[FC5] LTC23920-SCIM XIM server returns unexpected data
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-16 16:10 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: F-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 01:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ximtest.c (1.41 KB, text/plain)
2006-05-16 16:12 EDT, IBM Bug Proxy
no flags Details
LTC23920.patch (10.16 KB, text/plain)
2007-04-09 21:15 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2006-05-16 16:10:19 EDT
LTC Owner is: dmosby@us.ibm.com
LTC Originator is: takiguc@jp.ibm.com


Problem description:

Hardware Environment
    Machine: PPC64 (xclient), IA32 (xserver)

Is this reproducible? => Yes

Is the system (not just the application) hung? => No

Did the system produce an OOPS message on the console? => No

SCIM XIM server returns unexpected data on cross-platform 
environment.
I tried to connect to FC5 for PPC64 from FC5 for IA32 via SSH 
X11Forwarding.
My test program(ximtest.c) returns unexpected data.
Because of this situation, this program does not start.
Console log is as follows:
==================================================================
[ppc64]$ cc -o ximtest ximtest.c -lX11
[ppc64]$ export XMODIFIERS=@im=SCIM
[ppc64]$ ./ximtest
fevent = 0x3000000
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  2 (X_ChangeWindowAttributes)
  Value in failed request:  0x3200000
  Serial number of failed request:  40
  Current serial number in output stream:  41
==================================================================

When I run same program on IA32 machine, I got following result:
==================================================================
[i686]$ cc -o ximtest ximtest.c -lX11
[i686]$ ./ximtest
fevent = 0x3
==================================================================

I think ppc64's "fevent = 0x3000000" should be "fevent = 0x3".
I think it's byte-swap problem.

Additional information:

Created an attachment (id=16915)
ximtest.c
Comment 1 IBM Bug Proxy 2006-05-16 16:12:45 EDT
Created attachment 129268 [details]
ximtest.c
Comment 2 Mike A. Harris 2006-05-17 16:53:32 EDT
This should be filed against the "scim" component instead of "xorg-x11".
Please file bugs against the correct component to ensure the correct
maintainer receives them.

Thanks in advance.
Comment 3 IBM Bug Proxy 2006-05-22 14:27:25 EDT
----- Additional Comments From takiguc@jp.ibm.com  2006-05-22 11:26 EDT -------
"1st patch for this bug" works fine for this problem. 
Comment 5 Jens Petersen 2007-04-09 20:32:44 EDT
Sorry for the slow response - just saw this report now.

(In reply to comment #3)
> ----- Additional Comments From takiguc@jp.ibm.com  2006-05-22 11:26 EDT -------
> "1st patch for this bug" works fine for this problem. 

What patch is this referring to?
Comment 6 IBM Bug Proxy 2007-04-09 21:15:43 EDT
Created attachment 152077 [details]
LTC23920.patch
Comment 7 IBM Bug Proxy 2007-04-09 21:16:08 EDT
----- Additional Comments From shoji@jp.ibm.com  2007-04-09 21:10 EDT -------
 
1st patch for this bug.

Hello, Red Hat team.

> What patch is this referring to?
Please find the patch as attached this comment. 
Comment 8 Jens Petersen 2007-04-10 21:09:39 EDT
This patch is already in scim-1.4.5 upstream.  Moving to FC6.
Comment 9 Jens Petersen 2007-04-10 21:16:47 EDT
and in FC6 scim.

Note You need to log in before you can comment on or make changes to this bug.