Bug 192020 - up2date should not provide /etc/sysconfig/rhn/sources file in RHEL4
up2date should not provide /etc/sysconfig/rhn/sources file in RHEL4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Beth Nackashi
:
Depends On:
Blocks: 179644
  Show dependency treegraph
 
Reported: 2006-05-16 17:17 EDT by Beth Nackashi
Modified: 2013-01-10 03:52 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006:0494-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 11:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-05-16 17:17:18 EDT
Description of problem:
up2date.spec says:

%define is_RHEL_3 1

I believe what this is doing is causing up2date for RHEL4 to be built as RHEL3,
therefore it provides /etc/sysconfig/rhn/sources -- which is correct for RHEL3
but incorrect for RHEL4.

In RHEL3, redhat-release does not provide the sources file but up2date does.
In RHEL4, redhat-release provides the sources file but up2date should not.

Version-Release number of selected component (if applicable):
up2date-4.4.69-9

How reproducible:


Steps to Reproduce:
1.  Try to install up2date on a RHEL4 U3 box.
2.
3.
  
Actual results:

.qa.[root@s390-4as tmp]# rpm -Uvh up2date-*
Preparing...                ########################################### [100%]
        file /etc/sysconfig/rhn/sources from install of up2date-4.4.69-9
conflicts with file from package redhat-release-4AS-4.1

Expected results:


Additional info:
Comment 1 Beth Nackashi 2006-06-02 13:34:36 EDT
Moving this bug to MODIFIED state, because I see new packages and I assume that
means it's been fixed.
Comment 2 Beth Nackashi 2006-06-02 13:41:41 EDT
Retested on i386, ia64, x86_64, s390, s390x, and ppc.

Packages tested:
rhnlib-1.8.2-1.p23.1
up2date-4.4.67-4

I was able to successfully install up2date on the RHEL4 boxes.

Also, the up2date.spec file now says:
%define is_RHEL_3 0
Comment 4 Clifford Perry 2006-08-03 16:42:26 EDT
Bugzilla mass change did something I didnt expect. Fixing back. 

179644  	155570

Note You need to log in before you can comment on or make changes to this bug.