Bug 192095 - Fedora DS 1.0.2 won' allow a test user creation
Fedora DS 1.0.2 won' allow a test user creation
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 11:34 EDT by Razvan Sandu
Modified: 2008-08-11 19:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 13:48:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for the reported bug (45.24 KB, image/png)
2006-05-17 11:34 EDT, Razvan Sandu
no flags Details
This is the log of startconsole, as requested above (64.66 KB, text/plain)
2006-05-17 13:26 EDT, Razvan Sandu
no flags Details
This is the second screenshot, with parameters filled in (46.43 KB, image/png)
2006-05-17 13:27 EDT, Razvan Sandu
no flags Details

  None (edit)
Description Razvan Sandu 2006-05-17 11:34:04 EDT
Description of problem:

Hello,

Trying to test Fedora Directory Server on a FC5 box, as described in the Install
Guide and Release Notes.

When I try to create a test user in the predefined People group I keep getting
this error: "cannot save to directory server: java.Lang.IllegalArgumentException
(please see the attached screenshot)


Version-Release number of selected component (if applicable):

Fedora-DS- 1.0.2 (rpm version)
I used Sun's JRE 1.5.0 Update 6 (rpm version)


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
The creation of user fails.

Expected results:
Any type of object creation must be allowed

Additional info:
Comment 1 Razvan Sandu 2006-05-17 11:34:04 EDT
Created attachment 129332 [details]
screenshot for the reported bug
Comment 2 Rich Megginson 2006-05-17 11:47:05 EDT
I'm not really familiar with this error.  What is your locale/language/charset?
 It would be very helpful if you could run the console using 

startconsole -D 9 > output.log 2>&1

then reproduce the error, then attach output.log as an attachment to this bug.
Comment 3 Nathan Kinder 2006-05-17 11:52:20 EDT
In addition to the questions that Rich asked above, I'd like to know what values
you are putting into the fields when you create the test user.  The attached
screenshot does not show this information.
Comment 4 Razvan Sandu 2006-05-17 13:24:38 EDT
I will attach the log, as requested. I'm in Bucharest, Romania, but language is
set on English.

The parameters I've put in are not uncommon; to the cn parameter I tried to put
1. a single word or 2. the whole cn=xxx, dc=example, dc=com - I didn't knew the
requested syntax. It failed in both cases.

regards,
Razvan
Comment 5 Razvan Sandu 2006-05-17 13:26:23 EDT
Created attachment 129344 [details]
This is the log of startconsole, as requested above
Comment 6 Razvan Sandu 2006-05-17 13:27:40 EDT
Created attachment 129345 [details]
This is the second screenshot, with parameters filled in
Comment 7 Rich Megginson 2006-05-17 13:48:52 EDT
Ok.  The problem is that you are using the gcj version of java.  You will have
to use the Sun or IBM JRE.  Please refer back to the Install Guide for more
information.
Comment 8 Chandrasekar Kannan 2008-08-11 19:46:57 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.