Bug 192107 - guile-devel needs to require gmp-devel
guile-devel needs to require gmp-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: guile (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 13:05 EDT by Toshio Kuratomi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 08:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshio Kuratomi 2006-05-17 13:05:25 EDT
Description of problem:
The new guile has a dependency on libgmp.  This is picked up automatically for
the main guile package but guie-devel neds to explicitly Require: gmp-devel
otherwise other programs can't compile against libguile.

Version-Release number of selected component (if applicable):
guile-devel-1.8.0-3

How reproducible:
Everytime

Steps to Reproduce:
1. checkout gnotime from Fedora Extras CVS.
2. cd gnotime/devel
3. make mockbuild
  
Actual results:
Building will fail when we try to include libguile.h because gmp.h is missing:

In file included from /usr/include/guile/gh.h:24,
                 from ghtml.c:23:
/usr/include/libguile.h:48:17: error: gmp.h: No such file or directory
In file included from /usr/include/libguile.h:91,
                 from /usr/include/guile/gh.h:24,
                 from ghtml.c:23:
/usr/include/libguile/numbers.h:337: error: expected declaration specifiers or
'...' before 'mpz_t'
/usr/include/libguile/numbers.h:338: error: expected ')' before 'rop'

Expected results:
Build would succeed

Additional info:
Full logs of a failed gnotime build are here:

http://buildsys.fedoraproject.org/logs/fedora-development-extras/9521-gnotime-2.2.2-5.fc6/i386/

root.log has yum's dependency resolving that pulls in guile-devel but not gmp-devel.

build.log has the compilation and failure.
Comment 1 Miroslav Lichvar 2006-05-18 08:24:20 EDT
Fixed in guile-1.8.0-4.

Note You need to log in before you can comment on or make changes to this bug.