Bug 192114 - Updating from 1.1.23 to 1.2.0 causes printing to stop working.
Updating from 1.1.23 to 1.2.0 causes printing to stop working.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 13:36 EDT by Michael Carney
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 04:04:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Carney 2006-05-17 13:36:19 EDT
Description of problem: Upgrading from cups 1.1.23 to 1.2.0 causes printing
to stop working


Version-Release number of selected component (if applicable):1.2.0


How reproducible: yum update to latest version.


Steps to Reproduce:
1. Accept latest version of cups
2. Observe that printing no longer works.

  
Actual results: Printing no longer works.


Expected results: Printing continues to work.


Additional info:

I noticed the following errors in /var/log/cups/error_log after the update:

E [17/May/2006:10:23:56 -0700] Unknown configuration directive Autodetected on 
line 13 of printers.conf.

This error refers to the following line in printers.conf, which apparently is
no longer legal in 1.2.0:
Autodetected No



I [17/May/2006:10:23:56 -0700] Full reload complete.
I [17/May/2006:10:23:56 -0700] Listening to 127.0.0.1:631 on fd 0...
I [17/May/2006:10:23:56 -0700] Listening to /var/run/cups/cups.sock on fd 2...
E [17/May/2006:10:23:56 -0700] Unable to set ACLs on root certificate 
"/var/run/cups/certs/0" - Operation not supported


Also, using any of the printer manager tools results in the following error
dialog:

Unable to retrieve the printer list. Error message received from manager:
Connection to CUPS server failed. Check that the CUPS server is correctly 
installed and running. Error: host not found.

Removing 1.2.0 and restoring 1.1.23 causes printing to work again.
Comment 1 Tim Waugh 2006-05-17 13:46:08 EDT
What does 'rpm -q system-config-printer' say?
Comment 2 Tim Waugh 2006-05-17 13:49:13 EDT
Actually, more pertinent: cat /etc/cups/client.conf
Comment 3 Michael Carney 2006-05-17 14:01:09 EDT
/etc/cups/client.conf is empty:
175# ls -l /etc/cups/client.conf
-rw-r--r-- 1 root nobody 0 May  8 15:06 /etc/cups/client.conf
176#

176# rpm -q system-config-printer
system-config-printer-0.6.151.4-1
177#
Comment 4 Michael Carney 2006-05-17 15:11:16 EDT
BTW, I used KDE printmgr to originally set up the printer.

I just removed all configured printer information from /etc/cups, and 
restarted cups. I then reconfigured the printer information, this time using
system-config-printer. I saw the following in the error_log:

I [17/May/2006:11:56:08 -0700] Full reload is required.
I [17/May/2006:11:56:08 -0700] Loaded MIME database from '/etc/cups': 34 
types, 38 filters...
E [17/May/2006:11:56:08 -0700] Unable to queue job for destination 
"http://lucy:631/printers/hp"!
I [17/May/2006:11:56:08 -0700] Full reload complete.
I [17/May/2006:11:56:08 -0700] Listening to 127.0.0.1:631 on fd 0...
I [17/May/2006:11:56:08 -0700] Listening to /var/run/cups/cups.sock on fd 2...
E [17/May/2006:11:56:08 -0700] Unable to set ACLs on root certificate 
"/var/run/cups/certs/0" - Operation not supported
E [17/May/2006:11:56:21 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:56:29 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:56:29 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:57:25 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:57:43 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:57:58 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:58:03 -0700] CUPS-Get-Printers client-error-not-found: No 
destinations added.
E [17/May/2006:11:58:03 -0700] CUPS-Get-Classes client-error-not-found: No 
destinations added.
E [17/May/2006:11:58:03 -0700] CUPS-Get-Default client-error-not-found: No 
default printer
I [17/May/2006:11:58:03 -0700] Saving remote.cache...
I [17/May/2006:11:58:03 -0700] Listening to 127.0.0.1:631 (IPv4)
I [17/May/2006:11:58:03 -0700] Loaded configuration file 
"/etc/cups/cupsd.conf"
I [17/May/2006:11:58:03 -0700] Configured for up to 100 clients.
I [17/May/2006:11:58:03 -0700] Allowing up to 100 client connections per host.
I [17/May/2006:11:58:03 -0700] Using policy "default" as the default!
I [17/May/2006:11:58:03 -0700] Full reload is required.
I [17/May/2006:11:58:03 -0700] Saving job cache file 
"/var/cache/cups/job.cache"...
I [17/May/2006:11:58:03 -0700] Loaded MIME database from '/etc/cups': 33 
types, 38 filters...
I [17/May/2006:11:58:03 -0700] Loading job cache file 
"/var/cache/cups/job.cache"...
E [17/May/2006:11:58:03 -0700] Job 2 files have gone away!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 5!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 6!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 7!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 8!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 9!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 10!
E [17/May/2006:11:58:03 -0700] Missing <Job #> directive on line 11!
I [17/May/2006:11:58:03 -0700] Full reload complete.
I [17/May/2006:11:58:03 -0700] Listening to 127.0.0.1:631 on fd 0...
I [17/May/2006:11:58:14 -0700] Adding start banner page "none" to job 3.
I [17/May/2006:11:58:14 -0700] Job 3 queued on "hp" by "root".
I [17/May/2006:11:58:14 -0700] Started filter /usr/lib/cups/filter/pstops (PID 
6092) for job 3.
I [17/May/2006:11:58:14 -0700] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 6093) for job 3.
I [17/May/2006:11:58:14 -0700] Started backend /usr/lib/cups/backend/usb (PID 
6094) for job 3.
I [17/May/2006:11:59:38 -0700] Adding start banner page "none" to job 4.
I [17/May/2006:11:59:38 -0700] Job 4 queued on "hp" by "root".
I [17/May/2006:11:59:53 -0700] Scheduler shutting down normally.
I [17/May/2006:11:59:53 -0700] Saving remote.cache...
I [17/May/2006:11:59:53 -0700] Saving job cache file 
"/var/cache/cups/job.cache"...
I [17/May/2006:11:59:58 -0700] Listening to 127.0.0.1:631 (IPv4)
I [17/May/2006:11:59:58 -0700] Loaded configuration file 
"/etc/cups/cupsd.conf"
I [17/May/2006:11:59:58 -0700] Configured for up to 100 clients.
I [17/May/2006:11:59:58 -0700] Allowing up to 100 client connections per host.
I [17/May/2006:11:59:58 -0700] Using policy "default" as the default!
I [17/May/2006:11:59:58 -0700] Full reload is required.
I [17/May/2006:11:59:58 -0700] Loaded MIME database from '/etc/cups': 33 
types, 38 filters...
I [17/May/2006:11:59:58 -0700] Loading job cache file 
"/var/cache/cups/job.cache"...
I [17/May/2006:11:59:58 -0700] Full reload complete.
I [17/May/2006:11:59:58 -0700] Listening to 127.0.0.1:631 on fd 0...
E [17/May/2006:11:59:58 -0700] Unable to set ACLs on root certificate 
"/var/run/cups/certs/0" - Operation not supported
I [17/May/2006:11:59:58 -0700] Started filter /usr/lib/cups/filter/pstops (PID 
6128) for job 3.
I [17/May/2006:11:59:58 -0700] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 6129) for job 3.
I [17/May/2006:11:59:58 -0700] Started backend /usr/lib/cups/backend/usb (PID 
6130) for job 3.
I [17/May/2006:12:03:28 -0700] Saving remote.cache...
I [17/May/2006:12:03:28 -0700] Listening to 127.0.0.1:631 (IPv4)
I [17/May/2006:12:03:28 -0700] Loaded configuration file 
"/etc/cups/cupsd.conf"
I [17/May/2006:12:03:28 -0700] Configured for up to 100 clients.
I [17/May/2006:12:03:28 -0700] Allowing up to 100 client connections per host.
I [17/May/2006:12:03:28 -0700] Using policy "default" as the default!
I [17/May/2006:12:03:28 -0700] Full reload is required.
I [17/May/2006:12:03:28 -0700] Saving job cache file 
"/var/cache/cups/job.cache"...
I [17/May/2006:12:03:28 -0700] Loaded MIME database from '/etc/cups': 33 
types, 38 filters...
I [17/May/2006:12:03:28 -0700] Loading job cache file 
"/var/cache/cups/job.cache"...
I [17/May/2006:12:03:28 -0700] Full reload complete.
I [17/May/2006:12:03:28 -0700] Listening to 127.0.0.1:631 on fd 0...
E [17/May/2006:12:03:29 -0700] PID 6129 (/usr/lib/cups/filter/foomatic-rip) 
crashed on signal 9!
I [17/May/2006:12:03:29 -0700] Hint: Try setting the LogLevel to "debug" to 
find out more.
E [17/May/2006:12:03:29 -0700] PID 6130 (/usr/lib/cups/backend/usb) crashed on 
signal 9!
I [17/May/2006:12:03:29 -0700] Hint: Try setting the LogLevel to "debug" to 
find out more.
I [17/May/2006:12:03:37 -0700] Started filter /usr/lib/cups/filter/pstops (PID 
6254) for job 3.
I [17/May/2006:12:03:37 -0700] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 6255) for job 3.
I [17/May/2006:12:03:37 -0700] Started backend /usr/lib/cups/backend/hp (PID 
6256) for job 3.
I [17/May/2006:12:05:13 -0700] Started filter /usr/lib/cups/filter/pstops (PID 
6276) for job 4.
I [17/May/2006:12:05:13 -0700] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 6277) for job 4.
I [17/May/2006:12:05:13 -0700] Started backend /usr/lib/cups/backend/hp (PID 
6278) for job 4.

Now printing appears to be working again, this time using 1.2.0.
Comment 5 Tim Waugh 2006-05-18 04:04:42 EDT
Hmm, now we don't know what the original problem was then. :-/

The 'Autodetected no' error is harmless.
Comment 6 Michael Carney 2006-05-18 08:18:58 EDT
If you say so. Since 1.1.23 works fine with the existing config files, and 
1.2.0 does not, that seems to suggest that whatever update script that's run 
on the config files when the rpm is being updated isn't doing every thing it 
needs to, which required me to remove all configuration and reconfigure my 
printer in order to get it working again.

Note You need to log in before you can comment on or make changes to this bug.