Bug 19212 - In xdvi gs does not display figures propperly
In xdvi gs does not display figures propperly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 20400 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-16 20:55 EDT by Nicolai Langfeldt
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 03:11:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolai Langfeldt 2000-10-16 20:55:01 EDT
Quoting the xdvi FAQ (found in the tetex and xdvik distributions). 
Component above entered as tetex because the bug is evident under xdvi,
though it is a bug in ghostscript.

Nicolai the xdvik maintainer

7.  I am using gs 5.50 to render PostScript figures, and I find that
    sometimes characters appear on the wrong page.  Why is that?

This is a bug in ghostscript 5.50.  The following patch will fix it:

*** gdevx.c.orig        Fri Jul 17 07:31:27 1998
--- gdevx.c     Sat Oct 17 23:42:50 1998
***************
*** 59,65 ****
    ((gx_device_X *)(dev))->up_area = 0,\
    ((gx_device_X *)(dev))->up_count = 0
  #define update_flush(dev)\
!   if ( ((gx_device_X *)(dev))->up_area != 0 ) update_do_flush(dev)
  private void update_do_flush(P1(gx_device *));
  
  #define flush_text(dev)\
--- 59,66 ----
    ((gx_device_X *)(dev))->up_area = 0,\
    ((gx_device_X *)(dev))->up_count = 0
  #define update_flush(dev)\
!   if ( ((gx_device_X *)(dev))->up_area != 0 || IN_TEXT((gx_device_X
*)(dev)) )
\
!      update_do_flush(dev)
  private void update_do_flush(P1(gx_device *));
  
  #define flush_text(dev)\
Comment 1 Nicolai Langfeldt 2000-10-17 03:11:11 EDT
The patch is slightly badly formated, but it works correctly.  I just rebuilt
ghostscript (and tetex) and now have perfect xdvi viewing (and pdflatex
compiling).  Pls contact me for test cases if needed.
Comment 2 Jeff Johnson 2000-10-17 12:35:12 EDT
Fixed (patch applied) in ghostscript-5.50-10. Thanks for the patch (and offer of
test cases).
Comment 3 Tim Waugh 2001-02-02 11:38:12 EST
*** Bug 20400 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.