Bug 192129 - LTC23910-FC5: unknown/corrupt filesystem after swRAID install
LTC23910-FC5: unknown/corrupt filesystem after swRAID install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-17 15:38 EDT by IBM Bug Proxy
Modified: 2008-04-08 00:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 00:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovisexception (94.13 KB, text/plain)
2006-09-28 05:51 EDT, IBM Bug Proxy
no flags Details
ovisexception (94.13 KB, text/plain)
2006-09-28 05:52 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2006-05-17 15:38:49 EDT
LTC Owner is: thinh@us.ibm.com
LTC Originator is: barnetr@us.ibm.com


Problem description:

I initiated an install for "Fedora-development tree (aka rawhide), snapshot 
May1" onto a VIO client which is an SF4+ partition. The VIO server is latonalp1 
and I installed latonalp2 over the network, using a VNC configuration so that I 
could activate a VNC viewer on my laptop.

The requirement was for a swRAID install, so I created a swRAID (/dev/md0) with 
20000 blocks on both sda and sdb, with the Prep Boot and swap devices on sdf. 
The install ran clean to the point where it prompted me to reboot. Upon reboot, 
the vterm on the attached HMC was showing the following:

/pci@800000020000004/pci@2,4/pci1069,bl66@l/scsi@0/sd@d,0:-1,/etc/yaboot.conf:
Unknown or corrupt filesystem
Can't open config file
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-0.18)
Enter "help: to get some basic usage information
Default supplied on the command line: vnc
boot:

If I press Enter at this stage, I get the following:

can't get <device_type> for device:
Please wait, loading kernel...
can't get <device_type> for device:
:-l,/vmlinux: Unable to open file, Invalid device
boot:

I have been able to re-initiate the network install and select "Update" instead 
of "New Installation" and it completes in a matter of seconds saying that 
everything is successfully updated, then the partition reboots back to the same 
error messages.

The HMC attached to this system is sqh6lte.upt.austin.ibm.com with the usual 
hscroot/abc123 password information, so feel free to take a look as you feel 
appropriate.

Hardware Environment
Machine type (p650, x235, SF2, etc.): SF4+
Cpu type (Power4, Power5, IA-64, etc.): PPC-64


Is this reproducible? Yes.
If so, how long does it (did it) take to reproduce it? Install takes about 10-
15 minutes.

Is the system (not just the application) hung? Yes.
If so, describe how you determined this: Hangs on reboot with above errors.

Did the system produce an OOPS message on the console? No.

Is the system sitting in a debugger right now? No.

I have now seen the same problem on a Squadrons HV4 partition (mithraslp1). 
This time I defined the swRAID (/dev/md0) on disks sdc and sdd, with the Boot 
and Swap devices also on the sdd disk. It installed cleanly and prompted me to 
reboot, the system stops at the boot: prompt indicating that a filesystem is 
unknown or corrupt.

As I have now seen this on multiple systems, I am increasing the priority to P1 
and the severity to High. Call me in the lab on 8-8810 or send me a message if 
you have any questions or need more information.
Comment 1 Jeremy Katz 2006-05-22 13:22:54 EDT
Please file bugs against the devel tree properly instead of filing them against FC5.

This looks like something in yaboot's raid handling has gone wonky
Comment 2 IBM Bug Proxy 2006-08-31 22:16:23 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
              Owner|thinh@us.ibm.com            |kumarr@us.ibm.com
          QAContact|thinh@us.ibm.com            |kumarr@us.ibm.com




------- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-08-31 22:11 EDT -------
RH,

Any update?

Richard,

Are you still seeing this with the latest/most recent tree? 
Comment 3 IBM Bug Proxy 2006-09-21 11:26:01 EDT
----- Additional Comments From noelsr@us.ibm.com  2006-09-21 11:23 EDT -------
Ivy, could you look into this? 
Comment 4 IBM Bug Proxy 2006-09-21 22:30:56 EDT
------- Additional Comments From liyuanly@cn.ibm.com  2006-09-21 22:27 EDT -------
(In reply to comment #8)
> Ivy, could you look into this? 
OK, I will take care of it.
I will find the install source to verify. 
Comment 5 IBM Bug Proxy 2006-09-25 11:39:51 EDT
----- Additional Comments From liyuanly@cn.ibm.com  2006-09-25 01:57 EDT -------
During reboot phase, it passed the original failed place, since it has loaded
the kernel successfully. But it was not able to locate root filesystem.

The output of reboot FYI:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Config file read, 1024 bytes
Welcome
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-2.fc6)
Enter "help" to get some basic usage information
Default supplied on the command line: vnc
boot: vnc
Please wait, loading kernel...
vnc:2,/vmlinux: Unable to open file, Invalid device
boot:
Please wait, loading kernel...
   Elf64 kernel loaded...
OF stdout device is: /vdevice/vty@30000000
Hypertas detected, assuming LPAR !
command line: root=/dev/md0 ro console=hvc0 rhgb quiet
memory layout at init:
  alloc_bottom : 0000000002300000
  alloc_top    : 0000000008000000
  alloc_top_hi : 0000000060000000
  rmo_top      : 0000000008000000
  ram_top      : 0000000060000000
Looking for displays
instantiating rtas at 0x0000000007710000 ... done
0000000000000000 : boot cpu     0000000000000000
0000000000000002 : starting cpu hw idx 0000000000000002... done
0000000000000004 : starting cpu hw idx 0000000000000004... done
0000000000000006 : starting cpu hw idx 0000000000000006... done
0000000000000008 : starting cpu hw idx 0000000000000008... done
copying OF device tree ...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000002410000 -> 0x000000000241108d
Device tree struct  0x0000000002420000 -> 0x0000000002430000
Calling quiesce ...
returning from prom_init
Partition configured for 10 cpus.
Starting Linux PPC64 #1 SMP Wed Sep 6 17:17:26 EDT 2006
-----------------------------------------------------
ppc64_pft_size                = 0x19
physicalMemorySize            = 0x60000000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0x0000000000000000
htab_hash_mask                = 0x3ffff
-----------------------------------------------------
Linux version 2.6.17-1.2630.fc6 (brewbuilder@js20-bc2-9.build.redhat.com) (gcc
version 4.1.1 20060828 (Red Hat 4.1.1-20)) #1 SMP Wed Sep 6 17:17:26 EDT 2006
[boot]0012 Setup Arch
No ramdisk, default root is /dev/sda2
EEH: No capable adapters found
PPC64 nvram contains 7168 bytes
[boot]0015 Setup Done
Built 1 zonelists.  Total pages: 24576
Kernel command line: root=/dev/md0 ro console=hvc0 rhgb quiet
[boot]0020 XICS Init
xics: no ISA interrupt controller
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 32768 bytes)
time_init: decrementer frequency = 511.643000 MHz
time_init: processor frequency   = 1898.100000 MHz
Using pSeries machine description
Page orders: linear mapping = 24, virtual = 16, io = 12
Partition configured for 10 cpus.
Starting Linux PPC64 #1 SMP Wed Sep 6 17:17:26 EDT 2006
-----------------------------------------------------
ppc64_pft_size                = 0x19
physicalMemorySize            = 0x60000000
ppc64_caches.dcache_line_size = 0x80
ppc64_caches.icache_line_size = 0x80
htab_address                  = 0x0000000000000000
htab_hash_mask                = 0x3ffff
-----------------------------------------------------
Linux version 2.6.17-1.2630.fc6 (brewbuilder@js20-bc2-9.build.redhat.com) (gcc
version 4.1.1 20060828 (Red Hat 4.1.1-20)) #1 SMP Wed Sep 6 17:17:26 EDT 2006
[boot]0012 Setup Arch
Node 0 Memory: 0x0-0x60000000
No ramdisk, default root is /dev/sda2
EEH: No capable adapters found
PPC64 nvram contains 7168 bytes
Using shared processor idle loop
On node 0 totalpages: 24576
  DMA zone: 24576 pages, LIFO batch:1
[boot]0015 Setup Done
Built 1 zonelists.  Total pages: 24576
Kernel command line: root=/dev/md0 ro console=hvc0 rhgb quiet
[boot]0020 XICS Init
xics: no ISA interrupt controller
[boot]0021 XICS Done
PID hash table entries: 4096 (order: 12, 32768 bytes)
time_init: decrementer frequency = 511.643000 MHz
time_init: processor frequency   = 1898.100000 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 262144 (order: 5, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 4, 1048576 bytes)
freeing bootmem node 0
Memory: 1550656k/1572864k available (4544k kernel code, 22208k reserved, 1344k
data, 782k bss, 320k init)
Calibrating delay loop... 927.74 BogoMIPS (lpj=1855488)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
SELinux:  Starting in permissive mode
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 4096
Processor 1 found.
Processor 2 found.
Processor 3 found.
Processor 4 found.
Processor 5 found.
Processor 6 found.
Processor 7 found.
Processor 8 found.
Processor 9 found.
Brought up 10 CPUs
Node 0 CPUs: 0-9
sizeof(vma)=176 bytes
sizeof(page)=64 bytes
sizeof(inode)=768 bytes
sizeof(dentry)=232 bytes
sizeof(ext3inode)=1040 bytes
sizeof(buffer_head)=96 bytes
sizeof(skbuff)=240 bytes
migration_cost=0,1
PM: Adding info for No Bus:platform
NET: Registered protocol family 16
PCI: Probing PCI hardware
PCI: Probing PCI hardware done
Registering pmac pic with sysfs...
usbcore: registered new driver usbfs
usbcore: registered new driver hub
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
NET: Registered protocol family 2
IP route cache hash table entries: 16384 (order: 1, 131072 bytes)
TCP established hash table entries: 65536 (order: 5, 2097152 bytes)
TCP bind hash table entries: 32768 (order: 4, 1048576 bytes)
TCP: Hash tables configured (established 65536 bind 32768)
TCP reno registered
PM: Adding info for vio:vio
vio_bus_init: processing c00000005ffff260
PM: Adding info for vio:30000000
vio_bus_init: processing c00000005ffff418
IOMMU table initialized, virtual merging enabled
PM: Adding info for vio:30000002
vio_bus_init: processing c00000005ffff8b8
PM: Adding info for vio:30000004
vio_bus_init: processing c00000005ffffc10
PM: Adding info for vio:4000
vio_bus_init: processing c00000005ffffd48
PM: Adding info for vio:4001
vio_bus_init: processing c00000005ffffea0
PM: Adding info for vio:4002
IBM eBus Device Driver
PM: Adding info for ibmebus:ibmebus
scan-log-dump not implemented on this system
RTAS daemon started
audit: initializing netlink socket (disabled)
audit(1159160241.292:1): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 8192 (order 0, 65536 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 3ED3791291A29C07
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
vio_register_driver: driver hvc_console registering
HVSI: registered 0 devices
Generic RTC Driver v1.07
Linux agpgart interface v0.101 (c) Dave Jones
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
PM: Adding info for platform:serial8250
RAMDISK driver initialized: 16 RAM disks of 16384K size 4096 blocksize
PM: Adding info for platform:windfarm.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
EXT2-fs: unable to read superblock
isofs_fill_super: bread failed, dev=md0, iso_blknum=16, block=32
No filesystem could mount root, tried:  ext2 iso9660
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(9,0)

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
On the sda RHEL5 system, I mount /dev/sdb2 /mnt/boot, chroot /mnt, and vi
/boot/etc/yaboot.conf, the content is as following:

[root@ovislp1 /]# vi /etc/yaboot.conf
# yaboot.conf generated by anaconda

boot=/dev/sdb1
init-message=Welcome to Fedora Core!
Hit <TAB> for boot options

partition=2
timeout=80
install=/usr/lib/yaboot/yaboot
delay=5
enablecdboot
enableofboot
enablenetboot
nonvram
fstype=raw

image=/vmlinuz-2.6.17-1.2630.fc6
        label=linux
        read-only
        root=/dev/md0
        append="console=hvc0 rhgb quiet"


++++++++++++++++++++++++++++++++++++++++++++++++++++++
It seems it missed "initrd=..." entry. 
Comment 6 IBM Bug Proxy 2006-09-25 11:41:27 EDT
----- Additional Comments From liyuanly@cn.ibm.com  2006-09-25 01:50 EDT -------
Since both of the mentioned systems are hold for other bugs, I tested fc6-test3
on other system. The system has 3 disks, sda is occupied with RHEL5, so I used
sdb and sdc for swraid. The partion layout from RHEL5 system is as follows:
[root@ovislp1 ~]# fdisk -l

Disk /dev/sda: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1           1        8001   41  PPC PReP Boot
/dev/sda2               2          14      104422+  83  Linux
/dev/sda3              15        5221    41825227+  8e  Linux LVM

Disk /dev/sdb: 42.9 GB, 42949672960 bytes
255 heads, 63 sectors/track, 5221 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1           1        8001   41  PPC PReP Boot
/dev/sdb2               2          14      104422+  83  Linux
/dev/sdb3              15         269     2048287+  82  Linux swap / Solaris
/dev/sdb4             270        5221    39776940    5  Extended
/dev/sdb5             270        5221    39776908+  fd  Linux raid autodetect

Disk /dev/sdc: 37.5 GB, 37580963840 bytes
255 heads, 63 sectors/track, 4568 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1        4568    36692428+  fd  Linux raid autodetect

Disk /dev/md0: 78.3 GB, 78304247808 bytes
2 heads, 4 sectors/track, 19117248 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md0 doesn't contain a valid partition table


It could finish the clean installation, but still cannot reboot.
<to be continued> 
Comment 7 IBM Bug Proxy 2006-09-27 14:16:08 EDT
----- Additional Comments From kumarr@us.ibm.com (prefers email at kumarr@linux.ibm.com)  2006-09-27 14:11 EDT -------
Hello Redhat team, Would this bug be related to Bugzilla bug 206453? 
Comment 8 IBM Bug Proxy 2006-09-28 05:51:17 EDT
Created attachment 137298 [details]
ovisexception
Comment 9 IBM Bug Proxy 2006-09-28 05:51:44 EDT
----- Additional Comments From liyuanly@cn.ibm.com  2006-09-28 05:46 EDT -------
 
exception when install rhel5

This is the exception log which I mentioned in previous comment. After the
failed install of fc6-test3, the system could not install rhel5 on any disks. 
Comment 10 IBM Bug Proxy 2006-09-28 05:52:17 EDT
Created attachment 137300 [details]
ovisexception
Comment 11 IBM Bug Proxy 2006-09-28 05:52:32 EDT
------- Additional Comments From liyuanly@cn.ibm.com  2006-09-28 05:47 EDT -------
(In reply to comment #19)
>   [edit]
> exception when install rhel5
> 
> This is the exception log which I mentioned in previous comment. After the
> failed install of fc6-test3, the system could not install rhel5 on any disks.
 

You can also get a view  by vncviewer:9.3.111.26:1
no password. 
Comment 12 IBM Bug Proxy 2006-09-28 17:51:47 EDT
----- Additional Comments From kumarr@us.ibm.com (prefers email at kumarr@linux.ibm.com)  2006-09-28 17:48 EDT -------
Attention Redhat, I am rejecting this bug on the IBM side, since this is a dup
of RH Bugzilla bug 206453. We believe the fix for RH Bugzilla bug 206453 will
fix the  issue raised here in RH Bug 192129. 

Please let us know if you have any questions. 
Comment 13 Red Hat Bugzilla 2007-08-21 01:24:01 EDT
User pnasrat@redhat.com's account has been closed
Comment 14 Bug Zapper 2008-04-03 13:16:03 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 15 IBM Bug Proxy 2008-04-07 23:40:47 EDT
------- Comment From liyuanly@cn.ibm.com 2008-04-07 23:33 EDT-------
Hello Redhat,

Our linux test team no longer test Fedora distributions. We are focusing on
Redhat releases testing. Thanks.
Comment 16 John Poelstra 2008-04-08 00:39:51 EDT
closing per comment #12

Note You need to log in before you can comment on or make changes to this bug.