Bug 192188 - Missing BuildPrereq on libselinux-devel
Summary: Missing BuildPrereq on libselinux-devel
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libuser   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-18 08:55 UTC by Felipe Alfaro Solana
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 22:41:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felipe Alfaro Solana 2006-05-18 08:55:27 UTC
Description of problem:
The .spec file for libuser misses BuildPrereq: linselinux-devel.

Version-Release number of selected component (if applicable):
0.52.5-1.el4.1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e libselinux-devel
2. rpmbuild --rebuild libuser-0.52.5-1.el4.1.src.rpm
3. echo $?
  
Actual results:
Build failure if libselinux-devel is not installed.

Expected results:
rpmbuild shouldn't allow building of libuser if libselinux-devel is not installed.

Additional info:

Comment 1 Miloslav Trmač 2006-05-18 22:41:34 UTC
This is already fixed in Fedora Core since FC 4 and will therefore be fixed in
RHEL 5.  I have also commited the fix for RHEL 4, to be included with an libuser
erratum, if there will be one for other reasons.

Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.