Bug 19220 - Critical gnorpm fix
Summary: Critical gnorpm fix
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
: 19002 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-17 02:46 UTC by Alan Cox
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 03:51:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes set (4.22 KB, patch)
2000-10-17 03:50 UTC, Alan Cox
no flags Details | Diff

Description Alan Cox 2000-10-17 02:46:20 UTC
An elementary error in the rpmcompat.h file for 4.0 causes gnorpm to be
unusable on 7.0

--- rpmcompat.h~	Sat Mar 13 04:33:26 1999
+++ rpmcompat.h	Tue Oct 17 03:44:58 2000
@@ -18,7 +18,7 @@
 #ifndef __RPMCOMPAT_H__
 #define __RPMCOMPAT_H__
 
-#ifndef HAVE_RPM_3_0
+#if !defined(HAVE_RPM_3_0) && !defined(HAVE_RPM_4_0)
 #define FD_t int
 #define fdOpen open
 #define fdLseek lseek

Comment 1 Alan Cox 2000-10-17 03:50:08 UTC
Created attachment 4248 [details]
Fixes set

Comment 2 Alan Cox 2000-10-17 03:51:22 UTC
Together these two should fix all the bugs I can fix (ie the gdk errors from
popt clashes are not my problem).

Comment 3 Jeff Johnson 2000-10-18 13:45:06 UTC
Yes, the popt confusion is pretty ugly.

Fixed (by applying patch) in grnorpm-0.95.1-4.

Comment 4 Jeff Johnson 2000-10-18 13:46:32 UTC
*** Bug 19002 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.