Bug 192200 - IERR will occur with RenderAccel turned on with ATI's RN50
IERR will occur with RenderAccel turned on with ATI's RN50
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks: 176344 198694 200231 200936 201798
  Show dependency treegraph
 
Reported: 2006-05-18 08:10 EDT by Robert Hentosh
Modified: 2010-10-22 00:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHBA-2007-0317
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 13:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disable render acceleration for RN50 (612 bytes, patch)
2006-06-08 16:54 EDT, Anatoli Antonovitch
no flags Details | Diff
Disable 3D direct rendering support for RN50 (717 bytes, patch)
2006-06-08 16:55 EDT, Anatoli Antonovitch
no flags Details | Diff
Spec file (392.19 KB, application/octet-stream)
2006-06-08 16:58 EDT, Anatoli Antonovitch
no flags Details

  None (edit)
Description Robert Hentosh 2006-05-18 08:10:45 EDT
Description of problem: If an individual turns on RenderAccel in the xorg.conf
file, it will access invalid 3d registers on the RN50 which will result in in an
 IERR on Intel based chipsets.


Version-Release number of selected component (if applicable):


How reproducible: very (by using a cosmos (slideshow) program from a
gnome-screensaver rpm). 


Steps to Reproduce:
1. set RenderAccel to True in xorg.conf and restart X
2. ensure that radeon driver is used for RN50 on machine (can be add in card)
3. run slideshow program from gnome-screensaver
  
Actual results:
IERR and system lockup

Expected results:
no IERR - invalid registers should not be accessed by driver.

Additional info:
RenderAccel is not default on U3, so the exposure is low. And not all
appllications result in an IERR, however, using an analyzer we can see the
improper registers being accessed which is incorrect. Would like to get this
patched driver into next update (U5). ATI is submitting the patch to xorg. This
is not a problem on RHEL3 (Xfree does not have the code that implements RenderAccel)
Comment 1 Mike A. Harris 2006-05-18 17:02:38 EDT
Please escalate all RHEL issues through issue tracker.
Comment 2 Mike A. Harris 2006-05-31 15:25:33 EDT
(In reply to comment #0)
> Description of problem: If an individual turns on RenderAccel in the xorg.conf
> file, it will access invalid 3d registers on the RN50 which will result in in an
>  IERR on Intel based chipsets.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible: very (by using a cosmos (slideshow) program from a
> gnome-screensaver rpm). 
> 
> 
> Steps to Reproduce:
> 1. set RenderAccel to True in xorg.conf and restart X
> 2. ensure that radeon driver is used for RN50 on machine (can be add in card)
> 3. run slideshow program from gnome-screensaver
>   
> Actual results:
> IERR and system lockup
> 
> Expected results:
> no IERR - invalid registers should not be accessed by driver.
> 
> Additional info:
> RenderAccel is not default on U3, so the exposure is low. And not all
> appllications result in an IERR, however, using an analyzer we can see the
> improper registers being accessed which is incorrect. Would like to get this
> patched driver into next update (U5). ATI is submitting the patch to xorg. This
> is not a problem on RHEL3 (Xfree does not have the code that implements
RenderAccel)

Please have ATI submit a patch to Red Hat as well, relative to the latest
xorg-x11 released for RHEL4 which has been compile and runtime tested
if possible.


Comment 3 Anatoli Antonovitch 2006-06-01 14:02:51 EDT
Could you please provide me with a direct link to a source RPM for RHEL4 U5 on
your ftp site?
I will generate the patch for this bug.
Comment 4 Mike A. Harris 2006-06-02 18:32:34 EDT
Hi Anatoli,

FTP is no longer available on people.redhat.com, however
xorg-x11-6.8.2-1.EL.13.33 is now available for download via
http at the following URL:  http://people.redhat.com/mharris/testing/4E
The sources are in the SRPMS directory.

This is the most recent RHEL4 build, which is what is currently
in the pending RHEL4U4 release, however RHEL4U5 does not yet exist.

Let me know if you encounter any downloading problems as I've just
recently transitioned from ftp to http and am not sure if the kinks
are all worked out yet.

Thanks.
Comment 5 Anatoli Antonovitch 2006-06-08 16:54:22 EDT
Created attachment 130784 [details]
Disable render acceleration for RN50
Comment 6 Anatoli Antonovitch 2006-06-08 16:55:47 EDT
Created attachment 130785 [details]
Disable 3D direct rendering support for RN50
Comment 7 Anatoli Antonovitch 2006-06-08 16:58:01 EDT
Created attachment 130787 [details]
Spec file
Comment 10 Adam Jackson 2006-08-03 13:32:21 EDT
Concept approval, but nak on attachment #130785 [details], the proper fix is to disable
direct rendering entirely.
Comment 12 Adam Jackson 2006-08-04 19:41:03 EDT
For reference:

http://cvs.fedora.redhat.com/viewcvs/*checkout*/rpms/xorg-x11-drv-ati/devel/radeon-6.6.1-no-dri-on-rn50.patch?rev=1.1

Similar solution is correct for 6.8.2, modulo diff fuzz, not really worth
bothering ATI with.  Basically I just need PM ack to get this moving.
Comment 13 Daniel Riek 2006-08-24 20:59:49 EDT
The component of this request is planned to be updated in Red Hat enterprise
Linux 4.5.

This enhancement request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux maintenance release.

Product Management has requested further review of this enhancement by Red Hat
Engineering, for potential inclusion in a Red Hat Enterprise Linux Update
release for currently deployed products.

This enhancement is not yet committed for inclusion in an Update release. 
Comment 16 Larry Troan 2006-09-07 08:26:47 EDT
From QE: Do we have "...specific hardware to test with"?
Comment 17 Larry Troan 2006-09-07 11:19:07 EDT
Dell responds that most of the 9G goodies they just gave us has the "ES1000"
video chip on-board. The systems are in Westford and Raleigh. 

Per Fri, 4 Aug 2006 01:33:17, Jerry_Clement@Dell.com commented:
> Here is a list of all of the equipment that has shipped or is in
> transit. 
<snip>
>
> ORDER NUMBER    SERIAL NO.    SYSTEM
> 167013831       19NFDB1       PE1950
> 168200833       CZXFDB1       PE1950
> 167019267       9F06HB1       PE1950 woodcrest cpu, extra mem
> 167024432       95FRHB1       PE1955 (qty = 2)
>                 C5FRHB1
> 167038887       CK1JGB1       PE2900
> 168207507       JTDNGB1       PE2900
> 167113540       BKBPKB1       PE2900 woodcrest cpu, extra mem
> 167120636       G6K1DB1       PE2950
> 168191800       CTRFDB1       PE2950
> 167008104       JR0LKB1       PE2950 woodcrest cpu, extra mem
> 167449258       J332DB1       RH PWS490
> 181581706       4JXPKB1       RH PWS690 
Comment 18 Larry Troan 2006-09-07 11:28:21 EDT
Ajax, are we waiting for an updated patch from ATI (antonovi@ati.com) per your
comment #10 and your private comment #11 above? If so, this bug needs to be in
NEEDINFO -- it looks like my comment on 2006-06-28 accidently changed the status
to ASSIGNED. 
Comment 19 Adam Jackson 2006-09-07 20:28:45 EDT
(In reply to comment #18)
> Ajax, are we waiting for an updated patch from ATI (antonovi@ati.com) per your
> comment #10 and your private comment #11 above?

No, per comment #12 this just needs a rediff and backport to 6.8.2, I already
have the patch written.
Comment 20 Søren Sandmann Pedersen 2007-01-08 18:05:38 EST
DRI is already turned off for RN50. The only thing missing here is to forcefully
turn off RenderAccel even if the user explicitly turns it on.
Comment 21 Søren Sandmann Pedersen 2007-01-08 18:22:23 EST
in cvs.
Comment 22 Red Hat Bugzilla 2007-02-02 15:52:31 EST
Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2007:9144-02.
http://errata.devel.redhat.com/errata/showrequest.cgi?advisory=4904
Comment 23 Zack Cerza 2007-03-15 17:28:41 EDT
None of the screensavers lock up the machine, even when RenderAccel is forced on.
Comment 26 Red Hat Bugzilla 2007-05-01 13:33:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0317.html

Note You need to log in before you can comment on or make changes to this bug.