Bug 19225 - keytab-lilo is broken
keytab-lilo is broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 49233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-16 23:14 EDT by apeacock
Modified: 2014-03-19 07:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 15:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description apeacock 2000-10-16 23:14:32 EDT
The keytab-lilo program does not work out of the box.  No matter what
parameters are passed, keytab-lilo reports:

findkeymap: No such file or directory
cannot open file us.map
keytab-lilo: Keymap is empty
Comment 1 LENHOF 2001-04-12 17:01:49 EDT
The only thing which could help is that :

[root@mylinux /root]# keytab-lilo /lib/kbd/keymaps/i386/qwerty/us.kmap.gz
/lib/kbd/keymaps/i386/azerty/fr-latin1.kmap.gz > /boot/fr-latin1.ktl 
Loading /lib/kbd/keymaps/i386/qwerty/us.kmap.gz
Loading /lib/kbd/keymaps/i386/azerty/fr-latin1.kmap.gz
[root@mylinux /root]#

But after running lilo -v and rebooting....my keyboard isn't more in French...

Perhaps it will give you some ideas ?

Thanks
Jean-Yves
Comment 2 eric gerbier 2001-06-06 05:40:06 EDT
I have the same problem with redhat 7.1.

I solve it with the original lilo.tar.gz : I extract the keytab-lilo.pl (perl
script), use it, reboot
ant it works well

the bug is in the packaged keytab-lilo (elf program)
Comment 3 Jeremy Katz 2002-06-04 02:29:45 EDT
*** Bug 49233 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-06-04 15:23:30 EDT
Reassigning
Comment 5 Jeremy Katz 2002-06-04 16:23:13 EDT
This should be fixed in rawhide since we're using kbd again instead of
console-tools (the perl version isn't used because we don't want to have a
dependency on perl for lilo)

Note You need to log in before you can comment on or make changes to this bug.