Bug 192288 - constant pup crash
constant pup crash
Status: CLOSED DUPLICATE of bug 191630
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2006-05-18 15:39 EDT by scott stilwell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-18 15:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description scott stilwell 2006-05-18 15:39:26 EDT
Description of problem: Pup gives me the following error any time I try to
either install an RPM, click on add/remove software, or do anything involving

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.download anything from anywhere in RPM format, or click add/remove programs 
2.instantly you are greeted with the error box
3.selecting debug makes the error box go away but does not do anything from
there. i have tried and failed to locate the debug info on my system. 
Actual results:

Expected results:

Additional info:THis is what the error message contains:

Component: Software Updater
Summary: TB9275b279 downloadonly.py:26:config_hook:AttributeError: 'NoneType'
object has no attribute 'add_option'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 386, in ?
  File "/usr/sbin/pup", line 381, in main
    pup = PackageUpdater()
  File "/usr/sbin/pup", line 77, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 173, in
    optparser, types)
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 148, in __init__
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 26, in config_hook
    parser.add_option('', '--downloadonly', dest='dlonly', action='store_true',
AttributeError: 'NoneType' object has no attribute 'add_option'

Local variables in innermost frame:
conduit: <yum.plugins.ConfigPluginConduit instance at 0xb798d24c>
parser: None
Comment 1 Jeremy Katz 2006-05-18 15:50:27 EDT

*** This bug has been marked as a duplicate of 191630 ***
Comment 2 David Lawrence 2006-06-27 21:31:00 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.