Bug 192290 - kernel freeze when inserting orinoco card.
kernel freeze when inserting orinoco card.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-18 15:45 EDT by Martin Garton
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-15 17:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of stack. (309.12 KB, image/jpeg)
2006-05-18 15:45 EDT, Martin Garton
no flags Details
updated error screen shot. (277.64 KB, image/jpeg)
2006-05-30 14:31 EDT, Martin Garton
no flags Details

  None (edit)
Description Martin Garton 2006-05-18 15:45:01 EDT
Created attachment 129482 [details]
picture of stack.
Comment 1 Martin Garton 2006-05-18 15:45:01 EDT
Description of problem:

When inserting orinoco wireless card (pcmcia, not cardbus) there is a short
pause followed by a oops (or something similar)

Version-Release number of selected component (if applicable):
kernel 2.6.16-1.2206_FC6

How reproducible:

Insert card and wait a few seconds.

Additional info:

Unfortunately, I can't easily pinpoint when this started happening as I
previously believed it to be a hardware fault in the card.  However, I have
since had the card working on another machine with an ancient kernel.

All my other cards work fine, but are all cardbus.  So I don't know whether to
suspect orinoco, or non-cardbus pcmcia, or something else.

I have attached a pic of the stack trace that is displayed (or at least the part
of it I can see)
Comment 2 Martin Garton 2006-05-23 09:48:10 EDT
Is there any additional information I could provide that would help?
Comment 3 Martin Garton 2006-05-30 14:31:08 EDT
Created attachment 130243 [details]
updated error screen shot.

Error with "BUG: soft lockup detected on CPU#0" displayed at the top
Comment 4 Martin Garton 2006-05-30 14:33:19 EDT
Just to be clear, previous comment "#3" is now with kernel 2.6.16-1.2230_FC6
Comment 5 Martin Garton 2006-06-02 17:38:05 EDT
Testing with upstream kernel using vanilla git from 2006/05/31 does not hang in
this way, and the wireless card works.

It does however say:

pccard: PCMCIA card inserted into slot 0
cs: memory probe 0xa0000000-0xa0ffffff: clean.
pcmcia: registering new device pcmcia0.0
orinoco 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin
<proski@gnu.org>, et al)
orinoco_cs 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin
<proski@gnu.org>, et al)
setup_irq: irq handler mismatch
 <c0146754> setup_irq+0xfc/0x10f  <f8bd67dc> orinoco_interrupt+0x0/0xde9 [orinoco]
 <c01467d6> request_irq+0x6f/0x8b  <c0265190> pcmcia_request_irq+0x117/0x1fc
 <f8bb3470> orinoco_cs_probe+0x334/0x4bb [orinoco_cs]  <c0253a61>
ide_map_sg+0x26/0x71
 <c02fa0b7> _spin_lock_irqsave+0x9/0xd  <c025ac75> ide_dma_exec_cmd+0x1f/0x22
 <c014cddd> __alloc_pages+0x6d/0x2c2  <c011cf3b> activate_task+0x5a/0xa0
 <c01357ea> __mutex_init+0x30/0x4a  <c011cf3b> activate_task+0x5a/0xa0
 <c011d297> try_to_wake_up+0x316/0x320  <c0253a61> ide_map_sg+0x26/0x71
 <c02fa0b7> _spin_lock_irqsave+0x9/0xd  <c025ac75> ide_dma_exec_cmd+0x1f/0x22
 <c014cddd> __alloc_pages+0x6d/0x2c2  <c011cf3b> activate_task+0x5a/0xa0
 <c01357ea> __mutex_init+0x30/0x4a  <c011cf3b> activate_task+0x5a/0xa0
 <c011d297> try_to_wake_up+0x316/0x320  <c011c296> __wake_up_common+0x2f/0x53
 <c02fa078> _spin_unlock_irq+0x5/0x7  <c02f866f> schedule+0xa1b/0xa84
 <c026497a> pcmcia_device_probe+0x64/0xee  <c023e537> __driver_attach+0x0/0x8f
 <c023e471> driver_probe_device+0x45/0x9a  <c023e59c> __driver_attach+0x65/0x8f
 <c023defb> bus_for_each_dev+0x37/0x59  <c023e3d2> driver_attach+0x16/0x18
 <c023e537> __driver_attach+0x0/0x8f  <c023dc01> bus_add_driver+0x6f/0x10d
 <c013b268> sys_init_module+0x15da/0x1783  <c0265079> pcmcia_request_irq+0x0/0x1fc
 <c0103c07> sysenter_past_esp+0x54/0x75
eth1: Hardware identity 8002:0000:0001:0000
eth1: Station identity  001f:0003:0000:0008

Should I take that problem upstream first and see if it impacts the crash in the
fedora kernel specific problem?
Comment 6 Martin Garton 2006-06-15 17:37:53 EDT
Tested again with 2.6.16-1.2273_FC6 and the kernel no longer freezes.  I don't
know exactly when this was fixes, but can now be closed IMO.

Note You need to log in before you can comment on or make changes to this bug.